Bug 822246 - clocktest use of CPUSET_S not completely correct.
clocktest use of CPUSET_S not completely correct.
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
1.5
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Greg Nichols
Red Hat Kernel QE team
:
Depends On:
Blocks: 813533
  Show dependency treegraph
 
Reported: 2012-05-16 15:47 EDT by George Beshers
Modified: 2013-02-01 13:20 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: clocktest part of CORE test is not completely correct Consequence: CORE test will fail on very large systems (e.g.: 2048cpus) Fix: clocktest is fixed Result: CORE test will not fail anymore
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-01 13:20:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix sched_setaffinity error (1.00 KB, patch)
2012-05-21 10:37 EDT, George Beshers
no flags Details | Diff

  None (edit)
Description George Beshers 2012-05-16 15:47:43 EDT
Description of problem:
   It is a minor problem; I will have a patch ready tomorrow.
   Apparently we got lucky on the 1280cpu system, but 2048
   tickles the bug.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 George Beshers 2012-05-21 10:37:22 EDT
Created attachment 585832 [details]
Fix sched_setaffinity error
Comment 2 George Beshers 2012-05-21 10:41:41 EDT
To work with more than __CPU_SETSIZE
(set to 1024) the clocktest must be compiled
with  -DCPU_ALLOC.
Comment 10 errata-xmlrpc 2013-02-01 13:20:22 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0222.html

Note You need to log in before you can comment on or make changes to this bug.