Bug 822247 - Web Application Response Time Log File not being imported
Web Application Response Time Log File not being imported
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 5 (Show other bugs)
JON 3.1.0
All All
unspecified Severity high
: ER01
: JON 3.2.0
Assigned To: Thomas Segismont
Mike Foley
: FutureFeature
Depends On:
Blocks: jon310-sprint11/rhq44-sprint11
  Show dependency treegraph
 
Reported: 2012-05-16 15:48 EDT by Douglas Woods
Modified: 2014-01-02 15:38 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of Response Time Log file property (207.82 KB, image/png)
2012-05-16 15:48 EDT, Douglas Woods
no flags Details

  None (edit)
Description Douglas Woods 2012-05-16 15:48:10 EDT
Created attachment 585049 [details]
Screenshot of Response Time Log file property

Description of problem:
An applications runtime log file is not being imported when the EAP resource is imported into JON.

Version-Release number of selected component (if applicable):
JON v3.1
EAP v5.1.1

How reproducible:
Create an EAP instance and activate response time logging for a web application.
There will be a response time log created under the servers log/rt directory.
Import the EAP instance and check the application context under Inventory=>Connections settings is not being imported. Under JON v3.0.1 this response time log file is imported with the server import for the same server instance.

Steps to Reproduce:
1. Create an EAP instance and activate response time logging for a web appl
2. Import the EAP instance
3. View the Reponse Time Log file property under Inventory=>Connections Secttings for the application context.
  
Actual results:
No response time log file is imported with the server.
Expected results:
Response time log file is imported with the server.

Additional info:
Comment 1 Charles Crouch 2012-05-17 16:03:20 EDT
We should investigate this to see if we can reproduce, since its described as a regression.
Comment 3 Ian Springer 2012-05-22 11:14:49 EDT
This actually is not a regression. We never auto-discovered the location of the RT logfile for webapp context Resources, but it's a legitimate enhancement request.
Comment 4 Charles Crouch 2012-08-29 12:23:06 EDT
As per 8/20 triage marking as an RFE
Comment 5 Thomas Segismont 2013-06-25 09:52:59 EDT
Fixed in master

commit 488e304c2222eeaac300e5efda770531bf2d1a19
Author: Thomas Segismont <tsegismo@redhat.com>
Date:   Thu Jun 20 10:51:52 2013 +0200


The fix also includes an implementation of the same feature for EAP6 plugin's "Web Runtime" resource type.
Comment 6 Larry O'Leary 2013-09-06 10:31:01 EDT
As this is MODIFIED or ON_QA, setting milestone to ER1.
Comment 7 Filip Brychta 2013-11-19 10:54:56 EST
Verified that this works for both, EAP5 and EAP6, but only for default log location. 

Non-default log location scenario EAP5:
1- follow 'steps to reporoduce' from description above but use optional parameter 'logDirectory'.
You can follow https://access.redhat.com/site/documentation/en-US/JBoss_Operations_Network/3.1/html/Admin_Setting_up_Monitoring_Alerts_and_Operations/rt-configuration.html#enabling-rt
but use this optional parameter:
<init-param>
           <param-name>logDirectory</param-name>
          <param-value>/tmp</param-value>
</init-param>

Result:
Response Time Log File field on Web Application Context->Inventory->Connections settings is unset.
Comment 8 Thomas Segismont 2013-11-19 11:23:28 EST
There is no way to get the RTFilter configuration. Neither with EAP5, nor with EAP6 or Tomcat.

So you can't set the logDirectory param to an arbitrary value and expect the agent to discover it.

The three plugins will search for the RT log file in the default server log directory and in ${java.io.tmpdir}/rhq/rt
Comment 9 Filip Brychta 2013-11-19 11:46:38 EST
Moving to verified based on comment 7 and comment 8
Version :	
3.2.0.ER5
Build Number :	
2cb2bc9:225c796

Note You need to log in before you can comment on or make changes to this bug.