Bug 822264 - SOA-P v5.2 ESB deployments not available
SOA-P v5.2 ESB deployments not available
Status: CLOSED DUPLICATE of bug 821904
Product: JBoss Operations Network
Classification: JBoss
Component: Core Server (Show other bugs)
JON 3.1.0
x86_64 Linux
urgent Severity urgent
: ---
: JON 3.1.0
Assigned To: Len DiMaggio
Mike Foley
:
Depends On:
Blocks: jon310-sprint11/rhq44-sprint11
  Show dependency treegraph
 
Reported: 2012-05-16 17:19 EDT by Douglas Woods
Modified: 2012-05-22 12:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-22 12:17:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of No ESB deployments for SOA-P v5.2 instance (152.02 KB, image/png)
2012-05-16 17:19 EDT, Douglas Woods
no flags Details
rhq-server-log4j.log (70.27 KB, text/x-log)
2012-05-21 18:39 EDT, Douglas Woods
no flags Details
agent.log (815.93 KB, text/x-log)
2012-05-21 18:40 EDT, Douglas Woods
no flags Details

  None (edit)
Description Douglas Woods 2012-05-16 17:19:32 EDT
Created attachment 585062 [details]
Screenshot of No ESB deployments for SOA-P v5.2 instance

Description of problem:
When inventorying a SOA-P v5.2 instance using the default profile, a red exclamation appears next to the JBoss ESB deployments. So no ESB deployments are available for this SOA-P instance within JON.

Version-Release number of selected component (if applicable):
SOA-P v5.2(no EDS installed)
JON v3.1

How reproducible:
Boot up a default instance of SOA-P v5.2 and import the instance into JON. You will be required to configure the principal/credentials for this instance(e.g admin/admin). After JON has successfully connected to the instance and updated the inventory, a red exclamation will appear to the left of "JBoss ESB" for this instance and no ESB deployments will be available.

Steps to Reproduce:
1. Boot a SOA-P v5.2 default profile instance
2. Import into JON
3. Set principle/credentials to the instance via "Connection Settings"
  
Actual results:
No JBoss ESB inventory. See attached screenshot.

Expected results:
JBoss ESB deployments for the instance should be inventoried.
Note: same SOA-P v5.2 instance imports and provides JBoss ESB deployments with JON v3.0.1.

Additional info:
Comment 1 Charles Crouch 2012-05-17 13:54:35 EDT
Len,
Can you verify whether this occurs with JON 3.1 ER4
Thanks
Comment 2 Len DiMaggio 2012-05-21 11:48:00 EDT
Can you attach the server and JON logs?

Also - which JON 3.1 bits (build URL) was used?

Thx!
Comment 4 Douglas Woods 2012-05-21 18:38:37 EDT
Logs attached for both server and agent:

Also, the version I am using is the version from the RedHat CSP:
Here is the build information within the log:
2012-05-21 18:29:37,640 INFO  [org.jboss.system.server.Server] JBoss (MX MicroKernel) [4.2.3.GA (build: SVNTag=JBoss_4_2_3_GA date=200807181417)] Started in 1m:11s:895ms
Comment 5 Douglas Woods 2012-05-21 18:39:47 EDT
Created attachment 585902 [details]
rhq-server-log4j.log

rhq-server-log4j.log
Comment 6 Douglas Woods 2012-05-21 18:40:29 EDT
Created attachment 585903 [details]
agent.log

agent.log
Comment 7 Len DiMaggio 2012-05-22 12:14:24 EDT
It looks like the issue is:


https://bugzilla.redhat.com/show_bug.cgi?id=821904

Caused by: java.lang.ClassNotFoundException: org.rhq.plugins.jbossas5.util.FileContentDelegate





org.rhq.core.clientapi.agent.PluginContainerException: Failed to start component for resource Resource[id=11204, uuid=299225a7-b4da-41a7-8ddc-78168070d18a, type={JBossESB5}ESB, key=jboss.esb:service=MessageCounter, name=JBoss ESB, parent=SOA localhost:1099 default, version=5.2.0.GA].
	at org.rhq.core.pc.inventory.InventoryManager.activateResource(InventoryManager.java:1701)
	at org.rhq.core.pc.inventory.InventoryManager.refreshResourceComponentState(InventoryManager.java:2910)
	at org.rhq.core.pc.inventory.InventoryManager.processSyncInfo(InventoryManager.java:2661)
	at org.rhq.core.pc.inventory.InventoryManager.processSyncInfo(InventoryManager.java:2667)
	at org.rhq.core.pc.inventory.InventoryManager.processSyncInfo(InventoryManager.java:2667)
	at org.rhq.core.pc.inventory.InventoryManager.synchInventory(InventoryManager.java:1085)
	at org.rhq.core.pc.inventory.InventoryManager.handleReport(InventoryManager.java:1059)
	at org.rhq.core.pc.inventory.RuntimeDiscoveryExecutor.call(RuntimeDiscoveryExecutor.java:121)
	at org.rhq.core.pc.inventory.RuntimeDiscoveryExecutor.call(RuntimeDiscoveryExecutor.java:56)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
	at java.util.concurrent.FutureTask.run(FutureTask.java:138)
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301(ScheduledThreadPoolExecutor.java:98)
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:206)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
	at java.lang.Thread.run(Thread.java:662)
Caused by: java.lang.Exception: java.lang.NoClassDefFoundError: org/rhq/plugins/jbossas5/util/FileContentDelegate
	at org.rhq.core.pc.inventory.ResourceContainer$ComponentInvocationThread.call(ResourceContainer.java:639)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
	at java.util.concurrent.FutureTask.run(FutureTask.java:138)
	... 3 more
Caused by: java.lang.NoClassDefFoundError: org/rhq/plugins/jbossas5/util/FileContentDelegate
	at org.jbosson.plugins.jbossesb.ESB5Component.start(ESB5Component.java:62)
	at sun.reflect.GeneratedMethodAccessor42.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at org.rhq.core.pc.inventory.ResourceContainer$ComponentInvocationThread.call(ResourceContainer.java:634)
	... 5 more
Caused by: java.lang.ClassNotFoundException: org.rhq.plugins.jbossas5.util.FileContentDelegate
	at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
	at org.rhq.core.pc.plugin.PluginClassLoader.loadClass(PluginClassLoader.java:63)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
Comment 8 Len DiMaggio 2012-05-22 12:17:01 EDT

*** This bug has been marked as a duplicate of bug 821904 ***

Note You need to log in before you can comment on or make changes to this bug.