Bug 822290 - Mechanism for disabling firewall and selinux via kickstart should be re-considered due to firewalld switch
Mechanism for disabling firewall and selinux via kickstart should be re-consi...
Status: CLOSED DUPLICATE of bug 815540
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-05-16 20:21 EDT by Adam Williamson
Modified: 2012-05-16 21:53 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-05-16 21:53:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2012-05-16 20:21:16 EDT
See also this messy 17 report:


With Fedora 18 it's very likely the switch to firewalld by default will be back. This might well mean that system-config-firewall-base - which contains lokkit, which anaconda uses to disable firewall/selinux if you specify in a kickstart that they should be disabled - is no longer installed by default.

So we'd either need to move lokkit, or give anaconda a different way to enable/disable the firewall and selinux, or get s-c-f-b back into the default installed package set.

We might also need to teach lokkit how to disable firewalld, but that would seem to be outside the scope of this bug.
Comment 1 Chris Lumens 2012-05-16 21:53:27 EDT

*** This bug has been marked as a duplicate of bug 815540 ***

Note You need to log in before you can comment on or make changes to this bug.