Bug 822387 - RFE: XML-RPC method for listing my jobs
RFE: XML-RPC method for listing my jobs
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: reports (Show other bugs)
0.9
Unspecified Unspecified
unspecified Severity medium (vote)
: 0.9.4
: ---
Assigned To: James de Vries
:
: 649485 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-17 04:38 EDT by Vojtech Juranek
Modified: 2014-07-24 23:41 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-11 19:50:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vojtech Juranek 2012-05-17 04:38:17 EDT
Description of problem:
it seems there isn't any XML-RPC method available which would lists all my jobs.
There's jobs.mine() method, which however returns whole HTML page so I have to 
dig it from HTML code. It would be nice to have a XML-RPC method which would return a simple list of my jobs, if possible with a parameter which can specify status of the jobs (e.g. list only unfinished jobs etc.)
Comment 1 James de Vries 2012-08-29 22:15:33 EDT
Currently, jobs.list() is used to retrieve a list of jobs. However it does not support filtering by owner. I'll probably add this support in the form of two parameters: One to filter results by the owners username, and for when its not convenient to know your own username, a "mine" parameter, which when true will only return the jobs of the user you are currently logged in as.
Comment 2 Bill Peck 2012-09-04 13:53:18 EDT
*** Bug 649485 has been marked as a duplicate of this bug. ***
Comment 5 Dan Callaghan 2012-10-11 19:50:12 EDT
Beaker 0.9.4 has been released.

Note You need to log in before you can comment on or make changes to this bug.