Bug 822389 - not reload the multipath.conf after disabling the user_friendly_name
not reload the multipath.conf after disabling the user_friendly_name
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Ben Marzinski
Gris Ge
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-17 04:39 EDT by Xiaowei Li
Modified: 2015-01-26 19:10 EST (History)
12 users (show)

See Also:
Fixed In Version: device-mapper-multipath-0.4.9-59.el6
Doc Type: Bug Fix
Doc Text:
Cause: On reload, if a multipath device wasn't set to use user_friendly_names or a user defined alias, multipath was using it's existing name instead of setting it to the wwid Consequence: Disabling user_friendly_names did not cause the multipath device names to change back to wwids on reload. Fix: multipath now sets the device name to its wwid if no user_friendly_names or user defined aliases are set. Result: Disabling user_friendly_names will now allow device names to switch back to wwids on reload.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:50:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0458 normal SHIPPED_LIVE device-mapper-multipath bug fix and enhancement update 2013-02-20 16:07:30 EST

  None (edit)
Description Xiaowei Li 2012-05-17 04:39:50 EDT
Description of problem:
after disable the user_friendly_name then restart multipathd, the multipathed device name is not changed to wwid name.

cannot see this issue after switch non-user_friendly_name to user_friendly_name.

Version-Release number of selected component (if applicable):
[root@storageqe-09 ~]# rpm -qa|grep mult
device-mapper-multipath-0.4.9-56.el6.x86_64
device-mapper-multipath-libs-0.4.9-56.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. enable user_friendly_name and start multipathd
2. multipath -v2 to list the device
3. disable user_friendly_name then restart multipathd
4. execute multipath -ll

Actual results:
still see the user friendly name

Expected results:
should see the wwid name

Additional info: for details please refer to multipathd.log
Comment 2 Xiaowei Li 2012-06-03 10:43:41 EDT
any comments on this bz.
Comment 4 RHEL Product and Program Management 2012-07-10 02:57:44 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2012-07-10 19:12:31 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 7 Ben Marzinski 2012-10-10 13:11:33 EDT
Fixed.  Device names will now switch back to WWIDS on reload.
Comment 10 Gris Ge 2013-01-21 23:16:01 EST
VERIFY device-mapper-multipath-0.4.9-63.el6.x86_64

service multipathd reload will rename mpath if user_friendly_name changed.
Comment 12 errata-xmlrpc 2013-02-21 05:50:15 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0458.html

Note You need to log in before you can comment on or make changes to this bug.