Bug 82240 - postinstall script failed when upgrading
Summary: postinstall script failed when upgrading
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: libgcj   
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-20 11:41 UTC by Mario Mikocevic
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-20 12:06:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mario Mikocevic 2003-01-20 11:41:01 UTC
Description of problem:
# rpm -Uvh --replacepkgs libgcj-3.2.1-2.i386.rpm      
warning: libgcj-3.2.1-2.i386.rpm: V3 DSA signature: NOKEY, key ID 897da07a
Preparing...                ########################################### [100%]
   1:libgcj                 ########################################### [100%]
install-info: menu item `grepjar' already exists, for file `(none)'
error: %post(libgcj-3.2.1-2) scriptlet failed, exit status 1

# rpm -qa | grep libgcj                         
libgcj-3.2.1-2
libgcj-3.2.1-1

Comment 1 Jakub Jelinek 2003-01-20 11:54:42 UTC
This was a bug in libgcj-3.2.1-1 which has since been fixed.
If you had 3.2.1-1 installed, you have to cure it by hand (e.g. by deletting
the problematic dir entries).

Comment 2 Mario Mikocevic 2003-01-20 12:03:04 UTC
_NOT_ quite ->

# rpm -e libgcj-3.2.1-1

ok, that went fine but ->

# rpm -qa | grep libgcj
libgcj-3.2.1-2
# rpm -Uvh --replacepkgs libgcj-3.2.1-2.i386.rpm
warning: libgcj-3.2.1-2.i386.rpm: V3 DSA signature: NOKEY, key ID 897da07a
Preparing...                ########################################### [100%]
   1:libgcj                 ########################################### [100%]
install-info: menu item `grepjar' already exists, for file `(none)'
error: %post(libgcj-3.2.1-2) scriptlet failed, exit status 1

so error still exists ..

Even this does not work ->

# rpm -e gettext-0.11.4-5
# rpm -e libgcj-3.2.1-2  
# rpm -Uvh libgcj-3.2.1-2.i386.rpm              
warning: libgcj-3.2.1-2.i386.rpm: V3 DSA signature: NOKEY, key ID 897da07a
Preparing...                ########################################### [100%]
   1:libgcj                 ########################################### [100%]
install-info: menu item `grepjar' already exists, for file `(none)'
error: %post(libgcj-3.2.1-2) scriptlet failed, exit status 1


Comment 3 Jakub Jelinek 2003-01-20 12:06:12 UTC
But you haven't done the step I spoke about.
You have to edit /usr/share/info/dir by hand and remove the entries for grepjar,
jar and fastjar. Then everything will work again (as long as you don't
attempt to install the buggy libgcj-3.2.1-1 again).


Note You need to log in before you can comment on or make changes to this bug.