Bug 822405 - gnome-commander doesn't build with poppler-0.20.0
gnome-commander doesn't build with poppler-0.20.0
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-commander (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-17 05:43 EDT by Marek Kašík
Modified: 2012-05-18 07:02 EDT (History)
2 users (show)

See Also:
Fixed In Version: gnome-commander-1.2.8.15-4.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-18 07:02:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
add support for setErrorCallback() (1.95 KB, patch)
2012-05-17 08:35 EDT, Marek Kašík
no flags Details | Diff

  None (edit)
Description Marek Kašík 2012-05-17 05:43:18 EDT
Description of problem:
gnome-commander fails when built with new poppler-0.20.0.


Version-Release number of selected component (if applicable):
gnome-commander-3:1.2.8.15-3
Comment 1 Mamoru TASAKA 2012-05-17 07:15:05 EDT
At least
- Please write HERE the information how build fails
- provide a link to new poppler srpms or links
Comment 2 Mamoru TASAKA 2012-05-17 07:17:20 EDT
Also
- please announce on devel-announce when updating packages 
  like poppler changes API or so.
Comment 3 Marek Kašík 2012-05-17 08:35:08 EDT
Created attachment 585207 [details]
add support for setErrorCallback()

Hi Mamoru,

I'm sorry for not announcing this before on announce list. I've decided not to do so because there are just 5 packages which doesn't build with the poppler-0.20.0 and for which I don't have a link to a patch fixing this. I wanted to solve this individually by filling these bugs (but I see now that they are too brief).

I've prepared a patch for gnome-commander (see the attachment).

Regards

Marek
Comment 4 Marek Kašík 2012-05-17 08:39:50 EDT
The specific problem here is that poppler's upstream replace function setErrorFunction() with function setErrorCallback(). This new function has different API.

http://cgit.freedesktop.org/poppler/poppler/commit/?id=00549400f155d8e36b4ac718603fc945858fe50d
  - the commit which replaces the function

http://cgit.freedesktop.org/poppler/poppler/commit/?id=53f94df2ce21793914ccc153ba6b2fe5cbeb8371
  - fix of poppler's own usage of the function
Comment 5 Mamoru TASAKA 2012-05-17 23:43:18 EDT
Assigning. Thank you for attaching a patch. Will also contact the upstream.
Comment 6 Mamoru TASAKA 2012-05-18 07:02:16 EDT
Fixed (patch applied) in -4.fc18, thank you for reporting.
http://koji.fedoraproject.org/koji/buildinfo?buildID=319447

Note You need to log in before you can comment on or make changes to this bug.