Bug 822413 - inkscape doesn't build with poppler-0.20.0
inkscape doesn't build with poppler-0.20.0
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: inkscape (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-17 05:53 EDT by Marek Kašík
Modified: 2012-06-23 15:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-23 15:37:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch (26.86 KB, patch)
2012-05-26 20:44 EDT, Sandro Mani
no flags Details | Diff

  None (edit)
Description Marek Kašík 2012-05-17 05:53:49 EDT
Description of problem:
inkscape fails when built with new poppler-0.20.0.


Version-Release number of selected component (if applicable):
inkscape-0.48.2-5


Additional info:
This patch should fix the problem:
https://projects.archlinux.org/svntogit/packages.git/tree/trunk/poppler20.patch?h=packages/inkscape
Comment 1 Sandro Mani 2012-05-26 20:44:42 EDT
Created attachment 587053 [details]
Patch

Patch modified to apply cleanly on top of existing fedora package patches.
Comment 2 Alex Valavanis 2012-06-08 06:51:29 EDT
See upstream Inkscape bug: https://launchpad.net/bugs/1005565
Comment 3 Rex Dieter 2012-06-23 11:41:00 EDT
0.48.2-8

- fix icon/desktop-file scriptlets (#739375)
- drop .desktop vendor (f18+)
- inkscape doesn't build with poppler-0.20.0 (#822413)


http://koji.fedoraproject.org/koji/taskinfo?taskID=4190484
Comment 4 Rex Dieter 2012-06-23 11:59:48 EDT
boo, patch doesn't seem to work as advertised, looking closer now.
Comment 5 Rex Dieter 2012-06-23 12:39:36 EDT
Hrm, seems to build ok locally on my f17 x86_64 box with poppler-0.20.0-1 installed.  Something odd going on. (f18 gcc/glibc differences?, missing builddep?)
Comment 6 Kevin Kofler 2012-06-23 14:03:11 EDT
From the build failure, it looks like the first argument to the function "error" is being eaten somewhere, maybe something defining "error" as a macro?
Comment 7 Rex Dieter 2012-06-23 15:37:29 EDT
OK, the version of the patch from https://launchpad.net/bugs/1005565 works, build succeeds now.

Note You need to log in before you can comment on or make changes to this bug.