Bug 822421 - botan-1.11.3 is available
Summary: botan-1.11.3 is available
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: botan
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Thomas Moschny
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 912367
TreeView+ depends on / blocked
 
Reported: 2012-05-17 10:04 UTC by Upstream Release Monitoring
Modified: 2013-07-26 03:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-26 03:12:42 UTC


Attachments (Terms of Use)

Description Upstream Release Monitoring 2012-05-17 10:04:35 UTC
Latest upstream release: 1.10.1
Current version in Fedora Rawhide: 1.8.13
URL: http://botan.randombit.net/download.html

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 1 Upstream Release Monitoring 2012-06-18 07:32:18 UTC
Latest upstream release: 1.10.2
Current version in Fedora Rawhide: 1.8.13
URL: http://botan.randombit.net/download.html

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 2 Upstream Release Monitoring 2012-07-11 09:41:59 UTC
Latest upstream release: 1.10.3
Current version in Fedora Rawhide: 1.8.13
URL: http://botan.randombit.net/download.html

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 3 Upstream Release Monitoring 2012-07-21 18:03:10 UTC
Latest upstream release: 1.11.0
Current version in Fedora Rawhide: 1.8.13
URL: http://botan.randombit.net/download.html

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 4 Sander Hoentjen 2012-09-13 13:37:13 UTC
Hi Thomas,

Will you be updating botan soon?

Comment 5 Thomas Moschny 2012-09-14 10:12:17 UTC
Yes, will do, but for F18 it is too late I guess.

There are three packages that depend on botan:

- monotone
- ne7ssh
- softhsm

I have a patch for monotone, but I didn't test the other two yet. Want to help?

Comment 6 Upstream Release Monitoring 2012-10-31 09:28:47 UTC
Latest upstream release: 1.11.1
Current version in Fedora Rawhide: 1.8.14
URL: http://botan.randombit.net/download.html

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 7 Upstream Release Monitoring 2013-03-03 10:43:27 UTC
Latest upstream release: 1.11.2
Current version in Fedora Rawhide: 1.8.14
URL: http://botan.randombit.net/download.html

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 8 Upstream Release Monitoring 2013-04-15 10:04:47 UTC
Latest upstream release: 1.11.3
Current version in Fedora Rawhide: 1.8.14
URL: http://botan.randombit.net/download.html

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 9 Dan Horák 2013-07-17 15:44:22 UTC
Thomas, any progress here? qt-creator needs botan >= 1.10 to build with the system botan library

Comment 10 Thomas Moschny 2013-07-22 13:15:08 UTC
Was hoping for a monotone release, which did not happen yet. But will look into that soon.

Comment 11 Peter Robinson 2013-07-23 22:06:38 UTC
(In reply to Thomas Moschny from comment #10)
> Was hoping for a monotone release, which did not happen yet. But will look
> into that soon.

Can you apply the patch you have for monotone as you've been saying you'll do it soon for 9 months.

Comment 12 Thomas Moschny 2013-07-24 19:13:04 UTC
(In reply to Peter Robinson from comment #11)
> Can you apply the patch you have for monotone as you've been saying you'll
> do it soon for 9 months.

I must have missed the comment where you offered help checking that the other packages depending on Botan work with 1.10.X.

Anyway, here's what I intend to put in rawhide
http://koji.fedoraproject.org/koji/taskinfo?taskID=5652857

And just for the record, monotone now also needs a Lua 5.2 patch.

Comment 13 Peter Robinson 2013-07-24 20:22:14 UTC
> And just for the record, monotone now also needs a Lua 5.2 patch.

Well if that's not applied in rawhide it's broken anyway and shouldn't block the upgrade.

Comment 14 Thomas Moschny 2013-07-26 03:12:42 UTC
Updated to 1.10.5 in rawhide.


Note You need to log in before you can comment on or make changes to this bug.