Bug 822449 - Anaconda exits abnormally while installing RHEL6.3 Snapshot4 as 32bit Xen PV guest
Anaconda exits abnormally while installing RHEL6.3 Snapshot4 as 32bit Xen PV ...
Status: CLOSED DUPLICATE of bug 822697
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.3
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Anaconda Maintenance Team
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-17 07:35 EDT by Yuyu Zhou
Modified: 2012-05-18 10:24 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-18 10:24:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot (27.28 KB, image/png)
2012-05-17 07:35 EDT, Yuyu Zhou
no flags Details
anaconda log (3.35 KB, text/plain)
2012-05-17 07:36 EDT, Yuyu Zhou
no flags Details

  None (edit)
Description Yuyu Zhou 2012-05-17 07:35:05 EDT
Description of problem:
RHEL6.3 Snapshot4 -- RHEL6.3-20120516.0(as 32bit Xen PV guest in RHEL5.9) fails to install after running anaconda .

Version-Release number of selected component (if applicable):
guest:
RHEL6.0-20120516.0
anaconda-13.21.173-1.el6
host:
xen-3.0.3-139.el5
kernel-xen-2.6.18-318.el5

How reproducible:
Every time

Steps to Reproduce:
1. Install RHEL6.2 snapshot4 as 32bit Xen Paravirtualized guest via virt-manager, using network install tree:
http://download.devel.redhat.com/rel-eng/RHEL-6.3-Snapshot-4/6.3/Server/i386/os/

Actual results: (screenshot attached)
SELinux: Could not load policy file /etc/selinux/targeted/policy/policy.24: Invalid argument
/sbin/load_policy: Can't load policy: Invalid argument

Running anaconda 13.21.173, the Red Hat Enterprise Linux system installer - please wait.
Anaconda died after receiving signal 6.
Install exited abnormally [1/1]

Expected results:
Install should go ahead smoothly.

Additional info:
1. Rhel 6.3 Snapshot3(anaconda-13.21.171-1.el6) can be installed as 32bit Xen PV guest successfully.
2. Rhel 6.3 Snapshot4 can be installed as 64bit Xen PV guest, 32bit Xen HVM guest, 64bit Xen HVM guest successfully.
3. anaconda log attached.
4. The anaconda fail still be reproduce with "selinux=0" kernel parameter
Comment 1 Yuyu Zhou 2012-05-17 07:35:44 EDT
Created attachment 585193 [details]
screen shot
Comment 2 Yuyu Zhou 2012-05-17 07:36:10 EDT
Created attachment 585194 [details]
anaconda log
Comment 5 Lei Wang 2012-05-17 22:23:26 EDT
typo in description: s/RHEL6.0-20120516.0/RHEL6.3-20120516.0
Comment 6 Andrew Jones 2012-05-18 04:36:54 EDT
The selinux logs are probably unrelated. This is likely a dup of bug 822697
Comment 7 Chris Lumens 2012-05-18 10:24:01 EDT

*** This bug has been marked as a duplicate of bug 822697 ***

Note You need to log in before you can comment on or make changes to this bug.