This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 822454 - ImportError when exporting page as Markdown format
ImportError when exporting page as Markdown format
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Zim (Show other bugs)
16
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Robin Lee
Fedora Extras Quality Assurance
https://bugs.launchpad.net/zim/+bug/1...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-17 07:45 EDT by David Kovalsky
Modified: 2014-03-31 19:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-06 22:53:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Kovalsky 2012-05-17 07:45:56 EDT
I tried to export a page to text file via pandoc / Markdown, but Zim doesn't install markdown dependencies. 

I tried installing  python-markdown2 and pandoc, but that doesn't help. Zim still fails with the following traceback:


__init__.py:118:get_module:ImportError: No module named markdown (pandoc)

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/zim/gui/widgets.py", line 3176, in next_page
    return self.set_page(self._page + 1)
  File "/usr/lib/python2.7/site-packages/zim/gui/widgets.py", line 3154, in set_page
    page.init_uistate()
  File "/usr/lib/python2.7/site-packages/zim/gui/exportdialog.py", line 288, in init_uistate
    ext = zim.formats.get_format(self.uistate['format']).info['extension']
  File "/usr/lib/python2.7/site-packages/zim/formats/__init__.py", line 153, in get_format
    return get_format_module(name)
  File "/usr/lib/python2.7/site-packages/zim/formats/__init__.py", line 162, in get_format_module
    return zim.plugins.get_module('zim.formats', name)
  File "/usr/lib/python2.7/site-packages/zim/plugins/__init__.py", line 118, in get_module
    mod = __import__(modname)
ImportError: No module named markdown (pandoc)


Zim-0.56-1.fc16.noarch
Comment 1 David Kovalsky 2012-05-17 07:47:29 EDT
And the crash happens between display 2/3 and 3/3 window.
Comment 2 Fedora Update System 2012-05-24 03:23:30 EDT
Zim-0.56-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/Zim-0.56-2.fc16
Comment 3 Fedora Update System 2012-05-24 20:01:14 EDT
Package Zim-0.56-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing Zim-0.56-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8371/Zim-0.56-2.fc16
then log in and leave karma (feedback).
Comment 4 David Kovalsky 2012-05-25 11:24:31 EDT
Works for me, thanks for the packaging and taking this upstream!
Comment 5 Fedora Update System 2012-05-27 04:58:40 EDT
Zim-0.56-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/Zim-0.56-3.fc16
Comment 6 Fedora Update System 2012-05-27 21:19:01 EDT
Package Zim-0.56-3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing Zim-0.56-3.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8505/Zim-0.56-3.fc16
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-06-06 22:53:39 EDT
Zim-0.56-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.