Bug 822483 - Availability check stopped working after several operations.
Availability check stopped working after several operations.
Status: CLOSED DUPLICATE of bug 822905
Product: RHQ Project
Classification: Other
Component: Agent (Show other bugs)
4.4
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-17 09:29 EDT by Filip Brychta
Modified: 2012-05-18 11:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-18 11:10:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (424.95 KB, application/x-gzip)
2012-05-17 09:29 EDT, Filip Brychta
no flags Details
screenshot (89.13 KB, image/png)
2012-05-17 09:30 EDT, Filip Brychta
no flags Details

  None (edit)
Description Filip Brychta 2012-05-17 09:29:18 EDT
Created attachment 585222 [details]
logs

Description of problem:
Availability check stopped working and resources remained in undefined state. Steps required to get into this state described below.

Version-Release number of selected component (if applicable):
Version: 3.1.0.GA
Build Number: 07775cb:4ccefd7

GWT Version: 2.4.0
SmartGWT Version: 3.0

How reproducible:
always


Steps to Reproduce:
Prerequisites: rhq-agent, rhq-server and eap5 are running. EAP5 is imported into rhq inventory
1. stop rhq-agent
2. stop eap5
3. stop rhq-server
4. start agent
5. start rhq-server
6. start eap5
7. uninventory platform
8. use discovery -f agent prompt command if needed
9. import eap5

  
Actual results:
resources remain in undefined state (see screenshot.png)
output of agent prompt command avail:
sending> avail
Availability Report from May 17, 2012 1:37:29 PM
Resources in report: 0
Includes Only Changed Resources: false
sending> avail -f
Availability Report from May 17, 2012 1:37:38 PM
Resources in report: 0
Includes Only Changed Resources: false

Expected results:
resources are available, agent prompt command avail is working

Additional info:
system remains in this state until the rhq-agent is restarted, than status check works again.
Agent and server logs attached.
Comment 1 Filip Brychta 2012-05-17 09:30:14 EDT
Created attachment 585223 [details]
screenshot
Comment 2 Lukas Krejci 2012-05-18 09:41:29 EDT
Most likely, this is a duplicate of bug 822905
Comment 3 Filip Brychta 2012-05-18 11:10:09 EDT

*** This bug has been marked as a duplicate of bug 822905 ***

Note You need to log in before you can comment on or make changes to this bug.