Bug 822494 - planar test fails on non-x86
planar test fails on non-x86
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libyuv (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
http://code.google.com/p/libyuv/issue...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-17 10:17 EDT by Dan Horák
Modified: 2012-06-03 14:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-26 18:23:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Horák 2012-05-17 10:17:41 EDT
A test fails on non-x86 platforms with

...
[ RUN      ] libyuvTest.TestAttenuate
planar_test.cc:158: Failure
Value of: unatten_pixels[2][2]
  Actual: �
Expected: 192u
Which is: 192
[  FAILED  ] libyuvTest.TestAttenuate (8290 ms)
...

I did the computation done in ARGBUnattenuateRow_C() by hand and the result is
193 which is also what the test-suite returns. It seems to me that the SSE optimized and C versions return different results.


package version:
libyuv-0-0.7.20120505svn256

failed builds from s390 and ppc:
http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=662769
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=555553
Comment 1 Dan Horák 2012-05-17 11:08:45 EDT
and the reason is that "8.16 fixed point inverse table" is different between row_common.cc and row_posix.cc (which is the same as row_win.cc)

  T(0xf8), T(0xf9), T(0xfa), T(0xfb), T(0xfc), T(0xfd), T(0xfe), T(0xff)
vs.
  T(0xf8), T(0xf9), T(0xfa), T(0xfb), T(0xfc), T(0xfd), T(0xfe), 0x100
Comment 2 Dan Horák 2012-05-18 04:37:35 EDT
Fixed in upstream svn revision 268. Peter, please update the package or give me green light for doing so, thanks.

And I think this issue was also the reason for the failed EPEL builds.
Comment 3 Peter Lemenkov 2012-05-18 05:07:38 EDT
(In reply to comment #2)
> Fixed in upstream svn revision 268. Peter, please update the package or give me
> green light for doing so, thanks.
> 
> And I think this issue was also the reason for the failed EPEL builds.

Yep, that was the reason - I just tried to rebuild and it builds fine now. Will push new packages shortly.
Comment 4 Dan Horák 2012-05-18 05:29:03 EDT
Thanks. You seem to forget to update the svn revision in the Release if I see correctly.
Comment 5 Peter Lemenkov 2012-05-18 05:35:23 EDT
(In reply to comment #4)
> Thanks. You seem to forget to update the svn revision in the Release if I see
> correctly.

Yep, unfortunately I did. I won't rebuild it again - I just push fixed spec into Rawhide branch.
Comment 6 Dan Horák 2012-05-18 05:44:51 EDT
Yeah, no problem.

BTW I've also opened http://code.google.com/p/libyuv/issues/detail?id=36 to make libyuv usable.
Comment 7 Fedora Update System 2012-05-18 05:48:55 EDT
libyuv-0-0.8.20120518svn256.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/libyuv-0-0.8.20120518svn256.fc16
Comment 8 Fedora Update System 2012-05-18 05:49:30 EDT
libyuv-0-0.8.20120518svn256.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/libyuv-0-0.8.20120518svn256.el5
Comment 9 Fedora Update System 2012-05-18 05:49:44 EDT
libyuv-0-0.8.20120518svn256.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libyuv-0-0.8.20120518svn256.fc17
Comment 10 Fedora Update System 2012-05-18 05:49:57 EDT
libyuv-0-0.8.20120518svn256.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/libyuv-0-0.8.20120518svn256.el6
Comment 11 Fedora Update System 2012-05-18 16:25:55 EDT
Package libyuv-0-0.8.20120518svn256.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libyuv-0-0.8.20120518svn256.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8090/libyuv-0-0.8.20120518svn256.fc17
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2012-05-26 18:23:36 EDT
libyuv-0-0.8.20120518svn256.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2012-05-26 21:58:43 EDT
libyuv-0-0.8.20120518svn256.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2012-06-03 14:29:05 EDT
libyuv-0-0.8.20120518svn256.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2012-06-03 14:30:29 EDT
libyuv-0-0.8.20120518svn256.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.