This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 822495 - Fedora 17 DVD build does not contain device-mapper-multipath
Fedora 17 DVD build does not contain device-mapper-multipath
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: spin-kickstarts (Show other bugs)
17
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F17Blocker/F17FinalBlocker
  Show dependency treegraph
 
Reported: 2012-05-17 10:21 EDT by Mark Hamzy
Modified: 2012-05-21 12:04 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-21 12:04:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mark Hamzy 2012-05-17 10:21:50 EDT
Fedora 17 DVD build does not contain device-mapper-multipath.  When installing a machine with a multipath setup, it will appear to succeed.  However, when it is rebooted, multipath will not be setup.

I notice the following in the logs:

/var/log/anaconda/anaconda.log:14:11:00,097 DEBUG anaconda: no package matching device-mapper-multipath

And, upon further investigation, I notice that the device-mapper-multipath rpms are not on the media.

[root@miz03 ~]# mount /dev/sr0 /media/
mount: /dev/sr0 is write-protected, mounting read-only
[root@miz03 ~]# ls -l /media/Packages/d/device-mapper-*
-r--r--r--. 2 root root 155553 Apr 16 20:44 /media/Packages/d/device-mapper-1.02.74-6.fc17.ppc64.rpm
-r--r--r--. 2 root root 109837 May  9 16:14 /media/Packages/d/device-mapper-event-1.02.74-6.fc17.ppc64.rpm
-r--r--r--. 2 root root 103345 Apr 16 20:44 /media/Packages/d/device-mapper-event-libs-1.02.74-6.fc17.ppc64.rpm
-r--r--r--. 2 root root 102769 Apr 16 20:47 /media/Packages/d/device-mapper-event-libs-1.02.74-6.fc17.ppc.rpm
-r--r--r--. 2 root root 180713 Apr 16 20:48 /media/Packages/d/device-mapper-libs-1.02.74-6.fc17.ppc64.rpm
-r--r--r--. 2 root root 177213 Apr 16 20:48 /media/Packages/d/device-mapper-libs-1.02.74-6.fc17.ppc.rpm
Comment 1 Bruno Wolff III 2012-05-17 11:54:23 EDT
Was this with RC1?
Comment 2 Bruno Wolff III 2012-05-17 11:55:49 EDT
I am not sure this is really a blocker, but it looks like it could potentially be and should get reviewed.
Comment 3 Tom "spot" Callaway 2012-05-17 13:12:13 EDT
Confirmed that device-mapper-multipath isn't in the packages dir on RC1.
Comment 4 Adam Williamson 2012-05-17 13:37:24 EDT
commit b47d3f01d77b3a1f4c015b0f8f6f0fd74e8a33a7
Author: Bill Nottingham <notting@redhat.com>
Date:   Mon Sep 19 16:46:05 2011 -0400

    Drop device-mapper-multipath from @base (#739327)
    
    Anaconda will still install this where necessary. Long-term, this should be in some sort of advanced storage group.
    (And mdadm, lvm2, etc. would be listed there as well.)

That was before the release of 16, though, so I guess something still pulled it in via dependencies at that point.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Tim Flink 2012-05-17 15:03:57 EDT
Discussed at the 2012-05-17 Fedora 17 final go/no-go meeting. Accepted as a blocker for Fedora 17 final due to violation of the following Fedora 17 final release criterion [1]:

The installer must be able to complete an installation using any network-attached storage devices (e.g. iSCSI, FCoE, Fibre Channel)

Seeing as multipath is very much the norm for higher end networked storage, it isn't much of a conditional breakage.

[1] http://fedoraproject.org/wiki/Fedora_17_Final_Release_Criteria
Comment 6 Adam Williamson 2012-05-17 15:06:59 EDT
So I noticed fcoe-utils is also missing. I think we need a more systematic approach to ensuring all the stuff anaconda can add to the installation package set when it deems it appropriate is actually on the DVD. notting will create a new comps group for this purpose. So, see:

https://fedorahosted.org/rel-eng/ticket/5195



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Tim Flink 2012-05-18 17:20:11 EDT
Discussed in the 2012-05-18 blocker bug review meeting. The comps changes from comment #7 were included in Fedora 17 final RC2 and this needs to be tested to verify that the needed builds are now included on the DVD.

If they are, we are going to need a new build of spin-kickstarts before the next RC due to the Fedora 17 final release criterion [1] :

A Package-x-generic-16.pngspin-kickstarts package which contains the exact kickstart files used to build the release must be present in the release repository. The included kickstarts must define the correct set of release repositories.

[1] http://fedoraproject.org/wiki/Fedora_17_Final_Release_Criteria
Comment 9 Tim Flink 2012-05-21 12:04:54 EDT
Confirmed that device-mapper-multipath-0.4.9-25.fc17 and device-mapper-multipath-libs-0.4.9-25.fc17 are both present on the RC2 DVD media.

Note You need to log in before you can comment on or make changes to this bug.