This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 822604 - sbcl install hangs on tty input
sbcl install hangs on tty input
Status: CLOSED DUPLICATE of bug 822008
Product: Fedora
Classification: Fedora
Component: sbcl (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-17 11:34 EDT by Przemek Klosowski
Modified: 2012-05-17 11:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-17 11:42:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Przemek Klosowski 2012-05-17 11:34:22 EDT
Description of problem:
While upgrading my F16 install on Dell Inspiron mini to not-yet-released F17 (today we're at TC5 I believe) via preupgrade, the upgrade process got stuck updating sbcl (no activity/no progress for multiple minutes).  

I used the console (Ctrl-Alt-F2) to list active processes (ps -edalf), and found that sbcl install ran a series of scripts 

sh /usr/lib/common-lisp/bin/sbcl.sh install-clc

/usr/bin/sbcl --core /usr/lib/sbcl/sbcl-dist.core --noinform --sysinit /etc/sbcl.rc --userinit /dev/null --load /usr/lib/sbcl/install-clc.lisp

and when I traced the processes via strace -p <pid> (where <pid> was the process number I got from the output of the 'ps' command), I found out that the second process was stuck on an unfinished read(5,...) syscall. I found out from /proc/<pid>/fd that 5 was /dev/tty, so for  some reason the installation script went interactive and tried to read something from the console.

I did 'kill -9 <pid>', which aborted the sbcl installation script and allowed the upgrade to proceed.

Version-Release number of selected component (if applicable):
sbcl-1.0.56-1.fc17.x86_64

How reproducible:
not practical to reproduce this particular scenario (updating the entire distribution). 

I recently installed a F17 system from scratch, including the identical version of sbcl, and did not see this hangup, so it's possible that it only happens when sbcl is installed on top of an older sbcl. The laptop on which I had the problem had sbcl-1.0.51-1.fc16.x86_64.


Steps to Reproduce:
1. ran 'preupgrade' on F16, selected 'rawhide'
2. rebooted, entered GRUB menu and selected the 'upgrade' entry 
3. waited until sbcl started updating
  
Actual results:
the upgrade progress bar and text message stuck on 'Upgrading sbcl....'


Expected results:
upgrade process continues until successful completion


Additional info:
Comment 1 Rex Dieter 2012-05-17 11:42:58 EDT
Sounds like a dup of bug #822008

*** This bug has been marked as a duplicate of bug 822008 ***

Note You need to log in before you can comment on or make changes to this bug.