Bug 822626 - virt-ls error: "libguestfs: error: checksum: path: parameter cannot be NULL"
Summary: virt-ls error: "libguestfs: error: checksum: path: parameter cannot be NULL"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libguestfs
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Richard W.M. Jones
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 822490
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-17 16:15 UTC by Richard W.M. Jones
Modified: 2013-02-21 08:38 UTC (History)
8 users (show)

Fixed In Version: libguestfs-1.16.30-2.el6
Doc Type: Bug Fix
Doc Text:
Clone Of: 822490
Environment:
Last Closed: 2013-02-21 08:38:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0324 normal SHIPPED_LIVE libguestfs bug fix and enhancement update 2013-02-20 20:54:42 UTC

Description Richard W.M. Jones 2012-05-17 16:15:48 UTC
+++ This bug was initially created as a clone of Bug #822490 +++

Description of problem:

Using the virt-ls --checksum option provokes the following
error:

$ virt-ls -lR -a win2003.img --checksum=md5 / > win2003
libguestfs: error: checksum: path: parameter cannot be NULL

The error happens on any guest because of a simple bug in the
program where 'path' is used before it is set:

  if (checksum && is_reg (stat->mode)) {
    csum = guestfs_checksum (g, checksum, path);  <-- used
    if (!csum)
      exit (EXIT_FAILURE);

    output_string (csum);
  }

  path = full_path (dir, name);  <-- set

Version-Release number of selected component (if applicable):

1.16 (RHEL 6.3) and 1.17 (Fedora) both affected.

How reproducible:

100%

--- Additional comment from rjones@redhat.com on 2012-05-17 12:12:35 EDT ---

Fixed upstream:

https://github.com/libguestfs/libguestfs/commit/32765e440cee03bb7b89d1aa58c7dea4f55458c8

Comment 1 RHEL Product and Program Management 2012-07-10 08:07:54 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 2 RHEL Product and Program Management 2012-07-10 23:48:45 UTC
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.

Comment 4 Wei Shi 2012-11-02 02:14:13 UTC
Reproduced:
libguestfs-1.16.19-1.el6.x86_64

# virt-ls -lR -a Win2008r2-64-hvm.raw --checksum=md5 /
d 0777       8192 /
d 0777          0 /$Recycle.Bin
d 0777          0 /$Recycle.Bin/S-1-5-21-1887623760-3731238398-1460345420-500
libguestfs: error: checksum: path: parameter cannot be NULL
- 0777        129


Verified:
libguestfs-1.16.32-2.el6.x86_64

# virt-ls -lR -a Win2008r2-64-hvm.raw --checksum=md5 / > win2008r2
#

Comment 6 errata-xmlrpc 2013-02-21 08:38:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0324.html


Note You need to log in before you can comment on or make changes to this bug.