Bug 822675 - Errors using GlusterFS files through bind mount
Errors using GlusterFS files through bind mount
Status: CLOSED DEFERRED
Product: GlusterFS
Classification: Community
Component: fuse (Show other bugs)
3.2.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Darcy
http://community.gluster.org/q/gluste...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-17 14:21 EDT by Jeff Darcy
Modified: 2014-12-14 14:40 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-14 14:40:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Darcy 2012-05-17 14:21:11 EDT
From the GlusterFS community site...

Gluster 3.2.6/Fuse 2.8.7, across two nodes with replicated volume, for a shared hosting. Php-fcgi is used, so startup files stored in /mnt/glusterfs/var/www/fcgi. I can read them, copy them, move, delete etc without any problems. Mount -o bind, is used to map /mnt/glusterfs/var/www/fcgi to /var/www/fcgi. Apache can't start because of failure when trying to read any of php-fcgi startup files If i move (copy) php-fcgi startup files to another local folder - all works perfectly. I tried everything found on the net, but even can understand where problem is…

Apache gives me following error:

Wrapper php5-fcgi-startup cannot be accessed: (70008)Partial results are valid but processing is incomplete.

My guess it's something about FUSE mount options or whatever... But can't find anything reasonable
Comment 1 Joe Julian 2012-05-17 21:06:38 EDT
This is the results we were seeing with 64 bit inodes and a 32 bit apache module.
Comment 2 Amar Tumballi 2013-02-20 01:38:02 EST
any update on this? there are couple of inode32 enhancements which went into codebase recently.
Comment 3 Niels de Vos 2014-11-27 09:54:53 EST
The version that this bug has been reported against, does not get any updates from the Gluster Community anymore. Please verify if this report is still valid against a current (3.4, 3.5 or 3.6) release and update the version, or close this bug.

If there has been no update before 9 December 2014, this bug will get automatocally closed.

Note You need to log in before you can comment on or make changes to this bug.