Bug 822706 - [RFE] Allow Auto-subscribe Button to Register System When Relevant
[RFE] Allow Auto-subscribe Button to Register System When Relevant
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Michael Stead
Entitlement Bugs
: FutureFeature
Depends On:
Blocks: 771748 827225
  Show dependency treegraph
 
Reported: 2012-05-17 16:45 EDT by Matt Reid
Modified: 2013-01-07 22:52 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Register button is now shown on the Installed Software Tab when the system is not registered. The Auto-subscribe button is displayed once the system is registered.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:52:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Reid 2012-05-17 16:45:42 EDT
Description of problem:
The nice part about having the toolbar buttons before was that there was a Register button featured prominently, in with all the other confusing icons. With the introduction of menus and removal of those buttons, I was hoping we could have the Auto-subscribe button become the central action area, and be the register button if they weren't yet registered. That way they have something visible that they can easily click on to kick off the process of setting up their machine. 

As of subscription-manager-1.0.2-1, on an unregistered machine, the Auto-subscribe button is disabled and they have to go into the menu to see the option to register.

Is it possible to have the auto-subscribe button depend on system state and kick off the reg/sub flow if their system is unregistered, or kick off the sub flow when they're registered?
Comment 1 Michael Stead 2012-06-04 13:11:21 EDT
Fix Committed:

master - 2404d7a486dbe6279286e9b37970202bd115dd41
Comment 2 Michael Stead 2012-06-04 13:11:22 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Register button is now shown on the Installed Software Tab when the system is not registered. The Auto-subscribe button is displayed once the system is registered.
Comment 3 J.C. Molet 2012-06-19 15:29:13 EDT
testing with version: subscription-manager-gui-1.0.4-1.git.3.1768f90.el5


This works as described.  When unregistered the auto-subscribe button in the My Installed Products tab turns into a register button.

marking VERIFIED.
Comment 5 errata-xmlrpc 2013-01-07 22:52:38 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.