This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 822717 - fftw-libs conflicts with files from previous split packages fftw-*-{single,double}
fftw-libs conflicts with files from previous split packages fftw-*-{single,do...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: fftw (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Susi Lehtola
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-17 17:52 EDT by Przemek Klosowski
Modified: 2012-05-19 03:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-19 03:51:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Przemek Klosowski 2012-05-17 17:52:00 EDT
Description of problem:
when upgrading fc16 to fc17, packages fftw-*-{single,double} are apparently replaced with a unified package fftw-*. There are two problems:

- package version is non-monotonic--- !(3.3-4 > 3.3.1-2)

- even when the upgrade is forced by 'yum distribution-synchronization' it fails to execute because files /usr/lib64/libfftw3* belong to different packages now, are not properly accounted for, and yum refuses to overwrite them.

Version-Release number of selected component (if applicable):
fftw-libs-{single,double}-3.3.1-2.fc16.x86_64
fftw-libs-3.3-4.fc17.x86_64


How reproducible:
every time


Steps to Reproduce:
1. upgrade from FC16 to FC17
2. yum distribution-synchronization fftw*
  
Actual results:
Transaction check errors referring to /usr/lib64/libfftw3*

Expected results:
successful upgrade

Additional info:
Comment 1 Susi Lehtola 2012-05-19 03:51:41 EDT
fftw-libs-3.3.1-3.fc17 should be in the repos. Check that you have the base and updates repositories enabled.

NOTABUG

Note You need to log in before you can comment on or make changes to this bug.