This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 822794 - There is no return at the end of line of virt-viewer's verbose information.
There is no return at the end of line of virt-viewer's verbose information.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.3
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-18 03:49 EDT by yuping zhang
Modified: 2013-02-21 04:33 EST (History)
10 users (show)

See Also:
Fixed In Version: virt-viewer-0.5.2-12.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 04:33:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description yuping zhang 2012-05-18 03:49:12 EDT
Description of problem:
Connect a guest with virt-viewer -v,then close the console,there is no return at the end of last line.

Version-Release number of selected component (if applicable):
virt-viewer-0.5.2-8.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1.Start a guest.
2.Run #virt-viewer -v rhel6.2 or # virt-viewer --verbose rhel6.2
3.Close the console

Actual results:
# virt-viewer --verbose rhel6.2
Opening connection to libvirt with URI <null>
Guest rhel6.2 is running, determining display
Guest rhel6.2 has a spice display
Opening direct TCP connection to display at localhost:5901:-1
Guest rhel6.2 display has disconnected, shutting down[root@dhcp-*-* ~]#

Expected results:
It should have a return at the end of line of verbose info,like this:

# virt-viewer --verbose rhel6.2
Opening connection to libvirt with URI <null>
Guest rhel6.2 is running, determining display
Guest rhel6.2 has a spice display
Opening direct TCP connection to display at localhost:5901:-1
Guest rhel6.2 display has disconnected, shutting down
[root@dhcp-*-* ~]#

Additional info:
Comment 1 Daniel Berrange 2012-07-26 13:40:58 EDT
Should be pretty easy to fix this.
Comment 2 Christophe Fergeau 2012-09-18 10:10:46 EDT
I've sent a patch for this https://www.redhat.com/archives/virt-tools-list/2012-September/msg00044.html
Comment 3 Christophe Fergeau 2012-10-04 12:30:40 EDT
And it has been ACK'ed and pushed upstream, moving the bug to POST.
Comment 5 Geyang Kong 2012-10-15 04:02:55 EDT
This bug can be reproduce by following build:
virt-viewer-0.5.2-9.el6.x86_64

Verified pass on the following build:
virt-viewer-0.5.2-13.el6.x86_64

Steps:
1. Run virt-viewer $guest --verbose
2. Close the window.

Actual result:
[root@KP-T1 ~]# virt-viewer T1 --verbose
Opening connection to libvirt with URI <null>
Guest T1 is running, determining display
Guest T1 has a vnc display
Opening direct TCP connection to display at localhost:5901:-1
Guest T1 display has disconnected, shutting down
[root@KP-T1 ~]# 

So mark this bug as VERIFIED.
Comment 7 errata-xmlrpc 2013-02-21 04:33:07 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0361.html

Note You need to log in before you can comment on or make changes to this bug.