Bug 822815 - NPE during JGroups Channel Service startup
NPE during JGroups Channel Service startup
Status: CLOSED WORKSFORME
Product: JBoss Data Grid 6
Classification: JBoss
Component: EAP (Show other bugs)
6.1.0
Unspecified Unspecified
high Severity high
: ER3
: 6.1.0
Assigned To: Tristan Tarrant
Michal Linhard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-18 05:08 EDT by Michal Linhard
Modified: 2014-03-17 00:02 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Occasionally, when starting a JBoss Data Grid server, the JGroups subsystem would not start because of a NullPointerException during service installation, leaving the server in an unusable state. This situation does not affect data integrity within the cluster, and simply killing the server and restarting it solves the problem.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-28 09:00:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log from the failing node (4.61 KB, text/plain)
2012-05-18 05:08 EDT, Michal Linhard
no flags Details

  None (edit)
Description Michal Linhard 2012-05-18 05:08:28 EDT
Created attachment 585369 [details]
Log from the failing node

See the attached log
Comment 1 Tristan Tarrant 2012-05-18 08:18:18 EDT
How often does it happen ?
Comment 2 Michal Linhard 2012-05-18 10:12:37 EDT
I've seen it only once. It was when I was starting a 32node test, when 20th node was starting this happened. I then restarted the test and it worked alright.
Comment 3 Tristan Tarrant 2012-05-18 11:55:31 EDT
The code where this happens is (Lines 49-51):

for (Address address: this.channel.getView()) {
            String name = this.channel.getName(address);
            if (name.equals(localName) && !address.equals(localAddress)) {

So an NPE can only be if name is null or address is null. And name can be null only if address is null. Very odd.
Comment 4 mark yarborough 2012-05-23 10:21:25 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Tristan to supply CCFR
Comment 5 Misha H. Ali 2012-06-05 23:29:35 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-Tristan to supply CCFR+<remark>Tristan to supply CCFR</remark>
Comment 6 Misha H. Ali 2012-06-06 23:22:04 EDT
Flagging tristan for information about this bug.
Comment 7 Tristan Tarrant 2012-06-07 05:39:11 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-<remark>Tristan to supply CCFR</remark>+Occasionally, when starting a JDG server, the JGroups subsystem would not start because of a NullPointerException during service installation, leaving the server in an unusable state. This situation does not affect data integrity within the cluster, and simply killing the server and restarting it solves the problem.
Comment 8 Michal Linhard 2012-06-08 08:46:58 EDT
Happened again in CR1
http://www.qa.jboss.com/~mlinhard/hyperion/run176-elas-dist-32-CR1/logs/analysis/server/categories/cat6_entry0.txt
This time the test went ok to node 24 and failed.

Note You need to log in before you can comment on or make changes to this bug.