Bug 82282 - system hangs when X Starts up duirng a GUI install
system hangs when X Starts up duirng a GUI install
Status: CLOSED WORKSFORME
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
phoebe
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks: 79578
  Show dependency treegraph
 
Reported: 2003-01-20 15:22 EST by adler
Modified: 2007-04-18 12:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-10 12:39:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of lspci command (1.01 KB, text/plain)
2003-01-20 17:12 EST, adler
no flags Details

  None (edit)
Description adler 2003-01-20 15:22:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
My system freezes up, (i.e. keyboard and mouse dont respond) when
the X11 server starts up and displays the first graphical page of
the installation process. Both keyboard and mouse are plugged in.
When I run Red Hat 8.0, the system operates perfectly.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start Phoebe-2 gui install
2.wait for X11 server to startup
3.See first page of graphical installation, then try and move the mouse. It
don't move. <ctrl><alt><f1> does not get me into the text console.
    

Additional info:
Comment 1 adler 2003-01-20 15:26:40 EST
I have a Matrox 450, a ps/2 mouse and keyboard. I run a dual PIII system
with an ASUS mother board.
Comment 2 Bill Nottingham 2003-01-20 17:07:09 EST
Exact motherboard and chipset model?

(probably a duplicate of 80293)
Comment 3 adler 2003-01-20 17:12:30 EST
Created attachment 89449 [details]
output of lspci command

output from lspci command. This give you the motherboard chip set.
Comment 4 adler 2003-01-20 17:23:49 EST
The motherboard is a Tyan Tiger 133 model S1834D-I, dual slot 1 PIII motherboard.
VIA 694X, 1AGP/6 PCI/1 ISA, ATX form factor

This motherboard does have a problem with XFree86 4.X which was never resolved.
X11 will freeze up the system if I leave some graphics options turned on in
the XFree86 config file. What follow's is the Module section of my config file.

Section "Module"
        Load  "dbe"
        Load  "extmod"
#       Load  "fbdevhw"
#       Load  "glx"
#       Load  "record"
        Load  "freetype"
        Load  "type1"
#       Load  "dri"
EndSection

The stuff which is commented out allows my X11 setup to work without
freezing up my system. My guess is that these options are turned on
in the XFree86 setup for the installer or something similar which then
freezes up my system.

One thing to note. The freeze would occure only rarely on my current
system. (i.e. The way I would test it would be to leave the screen saver
running all night long. In the morning I would come in to my office and
find my system frozen up. After commenting out the stuff from the Module
section, the screen save could be left on over night and my system would
still be running.)

I hope this helps.

Cheers. Steve.

Comment 5 Jeremy Katz 2003-01-29 17:02:37 EST
Are your keyboard leds blinking when it freezes?
Comment 6 adler 2003-01-29 22:51:11 EST
nope. I see no flashing led lights on my keyboard. The is system totally dead.
Comment 7 Michael Fulbright 2003-01-30 15:46:31 EST
Reassigning to X component.
Comment 8 Mike A. Harris 2003-02-10 11:36:28 EST
Do a text mode install, then configure X, then attach your X server log
and config file from a failed X session.
Comment 9 adler 2003-02-10 11:57:19 EST
Sorry Mike, but I don't want to do that with a beta install, since I may risk
changing to a new version of XFree86 which is broken and I need to have my
system up and running. I'll keep my fingers crossed with 8.1 comes out and if I
do have problems them, I'll do as you suggested.

cheers. Steve.
Comment 10 Mike A. Harris 2003-02-10 12:39:49 EST
So if there is a problem still, what you're saying above is that
you don't actually want it fixed, but you'd rather we ship it broken,
so you can file another bug report when you try to install the final
OS release?  Makes sense.  ;o)

Seriously though, you're the only one who has reported this problem,
and I'm unable to reproduce it on G450 here.  I've asked others with
G450's to send me comments on if they can reproduce this, and so far
no problem reports.  I'm assuming the problem was either a local
transient, or is resolved in the current set of packages, and closing
it as WORKSFORME for now.

If the problem recurs, please reopen with the requested info.

Thanks.
Comment 11 Mike A. Harris 2003-02-10 12:43:42 EST
While chatting on IRC about this with other G450 users:

<ircuser> tyan tiger 133 is his problem
<ircuser> that board has AGP issues

Also, someone pointed out that your original report claimed to be
using ASUS motherboard, which you later claim to be Tyan motherboard.
Which is it?  ;o)

Comment 12 Mike A. Harris 2003-02-10 12:44:32 EST
<ircuser> he can fix it by installing without a network and sound card
initially; then making sure no IRQ sharing is being done; though its one of
those miliage may vary things
<ircuser> I hated that motherboard and I hate tyan for making it
Comment 13 adler 2003-02-10 16:24:06 EST
I understand Mike. My guess is that the reason the X11 install does not work is
the same reason I had to remove the GL module and turn AGP interupts off. This
all happend when redhat went from XFree86 3.X to 4.X. I have a very strong
feeling the problem has to do with the particular version of my motherboard. I'm
planning on upgrading the motherboard in anycase which case all this may be a
mutt point anyway.


Note You need to log in before you can comment on or make changes to this bug.