Bug 82284 - OpenOffice working at snails pace
OpenOffice working at snails pace
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: openoffice.org (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-20 16:05 EST by Sammy
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-17 10:00:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sammy 2003-01-20 16:05:55 EST
Tested openoffice-1.0.1, 1.0.2 and 643C under Phoebe-2, and rawhide. 
System is Pentium 4, 1.8GHz, with 2GB RDRAM. 
 
We are running a scientific program, which takes about 177MB of RAM and no disk i/o.  
We have 
been running this program for a long time and it had no effect on openoffice performance. 
Now it does. While all other applications run at normal speed openoffice windows take a  
minute or two two open after every click, e.g. click on the File menu, a minute later you'll see 
the menu. Other applications like Netscape 7.01, KDE applications, run at their normal 
speeds.
Comment 1 Michael Lee Yohe 2003-01-21 12:04:09 EST
You may wish to run OpenOffice from the terminal so that you can see messages
displayed to stderr.  Also, providing a strace of the process will assist
developers in seeing what is going on with your system.
Comment 2 Jakub Jelinek 2003-02-17 10:00:57 EST
A hack in the kernel has been removed and thus OOo which foolishly calls
sched_yield very often is yielded as it requests.
Try rawhide openoffice (e.g. 1.0.2-2).

Note You need to log in before you can comment on or make changes to this bug.