Bug 822851 - rhev-h TUI upgrade warning "Fail to Establish Libvirt Connection"
rhev-h TUI upgrade warning "Fail to Establish Libvirt Connection"
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
Unspecified Linux
high Severity high
: rc
: ---
Assigned To: Mike Burns
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-18 06:34 EDT by yuanquan chen
Modified: 2016-04-26 10:37 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-21 11:24:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/libvirtd.log (143.17 KB, text/x-log)
2012-05-21 01:53 EDT, yuanquan chen
no flags Details

  None (edit)
Description yuanquan chen 2012-05-18 06:34:19 EDT
Description of problem:
In the TUI upgrade menu, the warning of "Fail to Establish Libvirt
Connection" shows below the menu "Upgrade xxx to xxx"

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.3-20120516.0.el6

How reproducible:
100%

Steps to Reproduce:
1. install an old(older than rhev-hypervisor6-6.3-20120516.0.el6) rhev-h
to the machine
2. upgrade via TUI to rhev-hypervisor6-6.3-20120516.0.el6
  
Actual results:
In the TUI upgrade menu, the warning of "Fail to Establish Libvirt
Connection" shows below the menu "Upgrade xxx to xxx"

Expected results:
Establishing libvirt connection shouldn't fail, the warning shouldn't be
printed.

Additional info:
Comment 3 Mike Burns 2012-05-18 11:18:28 EDT
I've tried multiple upgrades from 6.3-20120509.1 to 6.3-20120516.0 and have not seen the "Failed to Establish Libvirt Connection" error yet.  Can you provide log files?  Exact Steps?  What setup was done on the old version prior to upgrading?
Comment 4 yuanquan chen 2012-05-21 01:53:16 EDT
Created attachment 585719 [details]
/var/log/libvirtd.log
Comment 5 yuanquan chen 2012-05-21 03:34:15 EDT
(In reply to comment #3)
> I've tried multiple upgrades from 6.3-20120509.1 to 6.3-20120516.0 and have
> not seen the "Failed to Establish Libvirt Connection" error yet.  Can you
> provide log files?  Exact Steps?  What setup was done on the old version
> prior to upgrading?

Hi Mike,

For the libvirtd.log, see comment #4. I also try to upgrade rhev-h from 6.3-20120502.3 to 6.3-20120509.1 without such libvirt connection error, while the upgrade of 6.3-20120509.1 to 6.3-20120516.0 will show this error every time. The steps of upgrade are shown below:

1. TUI install the older rhev-h to local disk
2. boot and check whether the installed rhev-h can boot normally
3. pxe boot to the new rhev-h to upgrade with TUI

Note You need to log in before you can comment on or make changes to this bug.