Bug 822853 - DeviceCreateError: ('Unknown option RAID0\nusage: mkfs.btrfs [options] dev [ dev ... ]....)
DeviceCreateError: ('Unknown option RAID0\nusage: mkfs.btrfs [options] dev [ ...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-18 06:36 EDT by Jan Stodola
Modified: 2012-05-18 13:48 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-18 09:27:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Stodola 2012-05-18 06:36:04 EDT
Description of problem:

anaconda 17.27 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 796, in create
    raise DeviceCreateError(str(e), self.name)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/deviceaction.py", line 241, in execute
    self.device.create(intf=intf)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 320, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 375, in doIt
    self.devicetree.processActions()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packages.py", line 122, in turnOnFilesystems
    anaconda.storage.doIt()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 383, in dispatch
    self.dir = self.steps[self.step].target(self.anaconda)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 88, in return_false
    func(*args, **kwargs)
DeviceCreateError: ('Unknown option RAID0\nusage: mkfs.btrfs [options] dev [ dev ... ]\noptions:\n\t -A --alloc-start the offset to start the FS\n\t -b --byte-count total number of bytes in the FS\n\t -d --data data profile, raid0, raid1, raid10 or single\n\t -l --leafsize size of btree leaves\n\t -L --label set a label\n\t -m --metadata metadata profile, values like data profile\n\t -M --mixed mix metadata and data together\n\t -n --nodesize size of btree nodes\n\t -s --sectorsize min block allocation\n\t -r --rootdir the source directory\nBtrfs Btrfs v0.19\n', 'f17')

Kickstart used for the installation:
install
lang en_US.UTF-8
keyboard us
network --onboot yes --device eth0 --bootproto dhcp --noipv6
timezone --utc America/New_York
rootpw  redhat
selinux --enforcing
authconfig --enableshadow --passalgo=sha512
firewall --service=ssh

clearpart --linux --drives=sda
ignoredisk --only-use=sda
bootloader --location=mbr --timeout=5

part btrfs.01 --grow --size=500
btrfs none --data=0 --label=f17 btrfs.01
btrfs / --subvol --name=root f17
btrfs /home --subvol --name=home f17
part biosboot --fstype=biosboot --size=1
part swap --size=512
part /boot --fstype=ext4 --size=500

%packages
@core
%end


Version-Release number of selected component (if applicable):
anaconda-17.27

How reproducible:
always

Steps to Reproduce:
1. install system using provided kickstart
  
Actual results:
anaconda traceback

Expected results:
successful installation

Additional info:
installation finishes successfully without the "--data=0" btrfs option in kickstart
Comment 2 David Lehman 2012-05-18 09:27:19 EDT
Your tree is way out of date. You need pykickstart-1.99.8-1, which was built on 14 March 2012.
Comment 3 Jan Stodola 2012-05-18 10:10:51 EDT
David,
pykickstart-1.99.7-1.fc17 is the latest version available for Fedora 17, see:
http://koji.fedoraproject.org/koji/packageinfo?packageID=13

Does it mean that this issue is not going to be fixed in Fedora 17?
Comment 4 David Lehman 2012-05-18 13:48:02 EDT
Sorry about that. It was fixed so early that I was sure it had gotten into the beta, but it didn't. I suppose it won't get into f17 at this point since we are trying hard to stabilize the final release.

Note You need to log in before you can comment on or make changes to this bug.