Bug 822919 - iostat_ios plugin doesn't work correctly / permissions wrong
iostat_ios plugin doesn't work correctly / permissions wrong
Status: CLOSED DUPLICATE of bug 746083
Product: Fedora EPEL
Classification: Fedora
Component: munin (Show other bugs)
el6
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-18 09:52 EDT by David Kovalsky
Modified: 2014-03-31 19:46 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-18 11:34:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Kovalsky 2012-05-18 09:52:07 EDT
I installed munin on a clean system and noticed that iostat_ios plugin didn't work. It failed with:

munin-run --pidebug --debug iostat_ios
# Processing plugin configuration from /etc/munin/plugin-conf.d/df
# Processing plugin configuration from /etc/munin/plugin-conf.d/hddtemp_smartctl
# Processing plugin configuration from /etc/munin/plugin-conf.d/munin-node
# Processing plugin configuration from /etc/munin/plugin-conf.d/postfix
# Processing plugin configuration from /etc/munin/plugin-conf.d/sendmail
# Set /rgid/ruid/egid/euid/ to /493/99/493 493 /99/
# Setting up environment
# About to run '/etc/munin/plugins/iostat_ios'
iostat_ios: No historic data present
can't create /var/lib/munin/plugin-state/iostat-ios.state: Permission denied at /etc/munin/plugins/iostat_ios line 212


The state dir is writable by the munin user:
pwd
/var/lib/munin/plugin-state

ls -la
total 8
drwxr-xr-x. 2 munin munin 4096 May 18 15:40 .
drwxr-xr-x. 5 munin munin 4096 May 18 15:40 ..
-rw-r--r--. 1 munin munin    0 May 13 18:15 yum.state



SELinux in Permissive.


But munin UID != GID:
munin:x:492:493:Munin user:/var/lib/munin:/sbin/nologin


If I do `chmod g+w /var/lib/munin/plugin-state/', the plugin starts working again. Is there any harm in making the state dir group writeable (for munin)? 

Or is this really a problem of munin not changing effective UID to munin (492)?


munin-1.4.7-4.el6.noarch
Comment 1 Kevin Fenzi 2012-05-18 11:34:09 EDT
This looks like another case of 746083. Moving over there for more debugging...

*** This bug has been marked as a duplicate of bug 746083 ***

Note You need to log in before you can comment on or make changes to this bug.