Bug 822930 - DNS info is removed after register to rhevm
DNS info is removed after register to rhevm
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
:
Depends On:
Blocks: 824621
  Show dependency treegraph
 
Reported: 2012-05-18 10:25 EDT by shine
Modified: 2016-04-26 10:56 EDT (History)
14 users (show)

See Also:
Fixed In Version: ovirt-node-2.3.0-8.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 824621 (view as bug list)
Environment:
Last Closed: 2012-07-19 10:13:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
VMMigError (8.78 KB, application/x-gzip)
2012-05-18 10:25 EDT, shine
no flags Details

  None (edit)
Description shine 2012-05-18 10:25:51 EDT
Created attachment 585425 [details]
VMMigError

Description of problem:
VM migration failed with empty resolv.conf after registered to RHEVM

Version-Release number of selected component:
rhev-hypervisor6-6.3-20120516.0.el6

How reproducible:
100%

Not Regression

Priority: High

Steps to Reproduce:
1. install rhev-hypervisor6-6.3-20120516.0.el6 to the machine
2. register it to rhevm
3. find the /etc/resolv.conf was empty
4. Connect to NFS storage, and create VMs on the RHEVH host


Actual results:
resolv.conf is empty, which results in DNS error and vm migration failure.[migerrorvdsm.log]
But the resolv.conf wouldn't be empty, after rebooted the rhevh. Then vm migration still failed.
If the hostnames of srchost and desthost are different, I modified the host-name setted on rhevm as the hostname of RHEVH, the migration is successful.[pic successfulmig.png]


Expected results:
vm migration should be successful.


Additional info:
Comment 1 Guohua Ouyang 2012-05-21 06:39:09 EDT
the root cause is that dns is removed after register to rhevm, to reproduce this can specify the dns on tui manually and then register to rhevm.

set priority to urgent to highlight this issue.

Mburns, 
Please help assign the bug to vdsm component it it's not owned by ovirt-node.
Comment 4 Mike Burns 2012-05-21 17:06:58 EDT
I looking into this some more and it's not exactly vdsm causing the problem (though that mght be where the fix is).

Sequence:

configure network
set different dns
apply changes
drop to shell
check /etc/resolv.conf -- setup correctly
service network restart
check /etc/resolv.conf -- empty


The rhevm registration does a service network restart which might be where we need to fix this
Comment 5 Fabian Deutsch 2012-05-22 04:43:51 EDT
Mike,

I could not reproduce the problem by following your steps.
In my tests /etc/resolv.conf was never empty. I configured the NIC with DNS and used the IP of a non-existent DNS server.
Comment 6 Fabian Deutsch 2012-05-22 05:56:18 EDT
Okay, I finally could reproduce this.
Comment 7 Fabian Deutsch 2012-05-22 09:38:29 EDT
The problem is the following:

The network is configured using DHCP, dhclient creates a copy of the original (a) /etc/resolv.conf in e.g. (b) /var/lib/dhclient/resolv.conf.predhclient.breth0 .
When dhclient is shut down, it overwrites /etc/resolv.conf with (b), thus, any changes that happened during the lifetime of dhclient to /etc/resolv.conf are lost.

If /etc/resolv.conf was empty before dhclient was started, and a DNS server is manually given in the TUI while dhclient is running, then - when a network restart happens - /etc/resolv.conf will be empty again and we've got this problem.

AFAIU the same applies to the ntp configuration.
Comment 11 Fabian Deutsch 2012-05-22 12:02:15 EDT
The following patch should fix this problem:
http://gerrit.ovirt.org/4674
Comment 14 yuanquan chen 2012-05-28 06:28:25 EDT
Verified with rhevh-6.3-20120523.1. the DNS won't be removed after restarting network service. It also successes to register to rhev-m and do vm migration.
Comment 15 Stephen Gordon 2012-06-14 11:33:15 EDT
The tech note for this was covered in a related bug, so no technical note required for this one.
Comment 17 errata-xmlrpc 2012-07-19 10:13:06 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0741.html

Note You need to log in before you can comment on or make changes to this bug.