Bug 822931 - For F16 rubygem-nokogiri incorrectly obsoletes ruby-nokogiri
For F16 rubygem-nokogiri incorrectly obsoletes ruby-nokogiri
Product: Fedora
Classification: Fedora
Component: rubygem-nokogiri (Show other bugs)
All Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-05-18 10:36 EDT by Troy Dawson
Modified: 2012-06-07 19:10 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-06-07 19:10:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Troy Dawson 2012-05-18 10:36:51 EDT
Description of problem:
rubygem-nokogiri-1.5.2-1.fc16 obsoletes ruby-nokogiri <= 1.5.0-2
But it doesn't provide the components of ruby-nokogiri, and there is a package still called ruby-nokogiri.

This only affects f16.  f17 and f18 are done correctly

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Have a F16 package that requires ruby-nokogiri
2. Try to install that package
Actual results:
Package install fails

Expected results:
Package install works, pulling in ruby-nokogiri

Additional info:
If the "Obsoletes: ruby-%{gemname} <= 1.5.0-2" line is pulled into the same check to see if we are running ruby 1.9, everything works out.

--- rubygem-nokogiri.spec	2012-05-18 09:34:28.048011608 -0500
+++ rubygem-nokogiri.spec.orig	2012-05-18 09:33:02.587018831 -0500
@@ -47,7 +47,6 @@
 BuildRequires:	rubygem(minitest)
 %if 0%{?ruby19} > 0
 BuildRequires:	rubygems-devel
-Obsoletes:	ruby-%{gemname} <= 1.5.0-2
 #BuildRequires:	ruby(racc)
@@ -58,6 +57,7 @@
 Requires:	ruby(abi) = %{rubyabi}
 Requires:	ruby(rubygems)
 Provides:	rubygem(%{gemname}) = %{version}-%{release}
+Obsoletes:	ruby-%{gemname} <= 1.5.0-2
 Nokogiri parses and searches XML/HTML very quickly, and also has
Comment 1 Mamoru TASAKA 2012-05-28 04:18:09 EDT
Umm.. as a result also master/f17 need fixing for upgrade path...
Comment 2 Fedora Update System 2012-05-28 23:16:46 EDT
rubygem-nokogiri-1.5.2-3.fc17 has been submitted as an update for Fedora 17.
Comment 3 Fedora Update System 2012-05-28 23:17:23 EDT
rubygem-nokogiri-1.5.2-1.fc16.1 has been submitted as an update for Fedora 16.
Comment 4 Fedora Update System 2012-05-29 17:58:54 EDT
Package rubygem-nokogiri-1.5.2-1.fc16.1:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rubygem-nokogiri-1.5.2-1.fc16.1'
as soon as you are able to.
Please go to the following url:
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-06-07 19:10:06 EDT
rubygem-nokogiri-1.5.2-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2012-06-07 19:10:55 EDT
rubygem-nokogiri-1.5.2-1.fc16.1 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.