Bug 822935 - Wizard is not reentrant
Wizard is not reentrant
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-18 10:59 EDT by Clayton Coleman
Modified: 2015-05-14 21:54 EDT (History)
4 users (show)

See Also:
Fixed In Version: rhc-0.93.11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-08 13:58:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clayton Coleman 2012-05-18 10:59:03 EDT
The wizard cannot be setup a second time, which means any error during the setup step requires the user to manually delete their conf file.

We should add a command like 'rhc setup' that invokes the wizard and allows the user to reexecute each step (with the current settings as defaults).  Right now there is no do over - if someone puts the wrong stuff in, that's it

"rhc setup" should be one of the new Commander commands and should be where the wizard code is invoked from (not sure if we would need wizard.rb in that case, unless you wanted to create some of that as helper steps that further break down the flow).
Comment 1 John (J5) Palmieri 2012-05-21 11:11:39 EDT
rhc setup was added on Friday, I need to add help documentation. Will put on QA when I have done that and pushed.
Comment 2 yquan 2012-05-28 02:26:15 EDT
It is fixed on devenv_1802, rhc-0.93.11




[root@localhost home]# rhc setup

Starting Interactive Setup for OpenShift's command line interface

It looks like you've not used OpenShift on this machine before.  We'll help get you setup with just a couple of questions. You can skip this in the future by copying your config's around:

/root/.openshift/express.conf
/root/.ssh/

To connect to openshift.redhat.com enter your OpenShift login (email or Red Hat login id): yquan@redhat.com
Password: *********

Created local config file: /root/.openshift/express.conf
express.conf contains user configuration and can be transferred across clients.

Your public ssh key needs to be uploaded to the server.  Would you like us to upload it for you? (yes/no) yes

We need to upload your public key to remote servers so it can be used.  First you need to name it.  For example "liliWork" or "laptop".  You can overwrite an existing key by naming it or pick a new name.

Current Keys:
    default - db:6c:7c:d9:72:79:81:ef:9a:95:83:40:b0:d7:49:c5

Provide a name for this key: |72ee3942|  

Sending new key 72ee3942 .. Success

We will now check to see if you have the necessary client tools installed.

Checking for git ... found

Checking for your namespace ... found namespace:
    yquan

Checking for applications ... found
    * jboss0 - http://jboss0-yquan.rhcloud.com/
    * py0 - http://py0-yquan.rhcloud.com/

Thank you for setting up your system.  You can rerun this at any time by calling 'rhc setup'. We will now execute your original command (rhc setup)

Note You need to log in before you can comment on or make changes to this bug.