Bug 822941 - Unable to check out from the Amazon MP3 store
Unable to check out from the Amazon MP3 store
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: banshee (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-18 11:13 EDT by Emmanuele Bassi
Modified: 2012-06-13 18:22 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-13 18:22:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Emmanuele Bassi 2012-05-18 11:13:17 EDT
Description of problem:

trying to check out anything from the Amazon MP3 store leads to an invalid security certificate warning.

Additional info:

see the equivalent bug in Launchpad:

https://bugs.launchpad.net/ubuntu/+source/banshee/+bug/980300

sadly, I can't find the patch because Launchpad is a big pile of fail.
Comment 1 Ray Strode [halfline] 2012-05-18 11:23:30 EDT
<ebassi> has anyone tried the amazon mp3 store plugin for banshee in f17?
<ebassi> probably not, given that it's broken and I can't seem to find anything about it except a bug on launchpad
<mizmo> ebassi, browsing it works for me in banshee but i havent tried to buy anything from it yet
<mizmo> in f16 that is
<ebassi> mizmo: f16 worked fine. since the update to f17 I can add tracks to the basket, but trying to 1-click buy them, or to check them out, fails
<ebassi> there's a bug on launchpad, but I can't find the patch they refer to because launchpad is a pile of fail
<ebassi> https://bugs.launchpad.net/ubuntu/+source/banshee/+bug/980300
<ebassi> and now https://bugzilla.redhat.com/show_bug.cgi?id=822941
<mizmo> :( well, if it still works in f16, then it's probably something wrong with the app and not amazon changing the api or whatever
<ebassi> yeah
<halfline> ebassi: seems to be gnome bug 673037
<kalev> ebassi: perhaps this is the fix? http://git.gnome.org/browse/banshee/commit/?id=a5c94f2e
<halfline> http://fpaste.org/YUtN/raw/
<kalev> ha, same patch!
<halfline> jinx
Comment 2 anonyme 2012-06-12 15:04:13 EDT
I confirm the problem on my F17
Comment 3 Emmanuele Bassi 2012-06-12 17:10:12 EDT
downloaded banshee 2.4.1 from koji - and it seems it already hit updates-testing - and I can confirm that the issue has been fixed.
Comment 4 Christian Krause 2012-06-13 18:22:53 EDT
Based on comment #3 I'll close this bug report. I have also verified, that the mentioned patch is included in 2.4.1.

Note You need to log in before you can comment on or make changes to this bug.