Bug 822950 - Problems when launching nautilus from terminal as root
Problems when launching nautilus from terminal as root
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
16
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-18 11:24 EDT by Ruben Roy
Modified: 2015-03-03 18:05 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-18 12:30:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ruben Roy 2012-05-18 11:24:59 EDT
Description of problem:
When launching nautilus from gnome terminal as root:
1. The date/time indicator at the middle of the taskbar changes to "DAY HH:MM" from the full date and time which had been configured using gnome tweak tool
2. Taps using the touchpad are not recognized. However moving the pointer is possible. Also the buttons near the touchpad work without problems
3. Problem 2 is solved when running the command "synclient TapButton1=1". But it reappears after it goes into suspend mode.
4. Logging out and logging in solves problems 1 and 2 but they can be reproduced again



Steps to Reproduce:
1. Start gnome terminal
2. run "su - -c nautilus"
Comment 1 Tomáš Bžatek 2012-05-18 12:30:05 EDT
Please don't run Gnome apps as root, there are many issues around and it's generally unsupported (mostly due to d-bus session bus limitations).

Do these issues appear only when running as root or even as normal user?
Comment 2 Ruben Roy 2012-05-18 15:27:14 EDT
Everything works as it should when running as a normal user.

Note You need to log in before you can comment on or make changes to this bug.