Bug 822975 - multiple --target option is no longer working
multiple --target option is no longer working
Status: CLOSED NEXTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: mock (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Clark Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-18 12:40 EDT by Levente Farkas
Modified: 2012-12-07 06:41 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-07 06:41:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Levente Farkas 2012-05-18 12:40:28 EDT
in the beginning (around 1.1.1) it was possible to use:
 --target i386,i686
this is very useful eg build glibc, openssl etc. on rhel-5 and the same apply to the kernel rpm on rhel-6 (in this case eg: i686,noarch). but it's no longer possible since mock do not install the src.rpm twice which means eg when build glibc which move SOURCE6 from the SOURCES/ dir to the buildroot that the second build will fail.

so either remove the possibility to add multiple target or fix it (ie. rerun the mock process from the beginning.

anyway it's not epel specific it's apply to the fedora package too.
Comment 1 Clark Williams 2012-08-01 22:08:03 EDT
Ok, I checked for multiple arch values in the option parser code and disallow them.

queued for next build.

Note You need to log in before you can comment on or make changes to this bug.