Bug 822978 - User reported an error with CLI after running into a timeout on rhc app create: no implicit conversion from nil to integer (TypeError)
User reported an error with CLI after running into a timeout on rhc app creat...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-18 12:49 EDT by Nam Duong
Modified: 2015-05-14 21:54 EDT (History)
4 users (show)

See Also:
Fixed In Version: rhc-0.93.13-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-08 13:59:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nam Duong 2012-05-18 12:49:19 EDT
Description of problem:
See thread: https://openshift.redhat.com/community/forums/openshift/hi-request-help-in-wordpress-on-openshift

Based on the output:
Johnson@Johnson-HP /home
$ rhc app create -a wordpress2 -t php-5.3 --rhlogin jkchua1@e.ntu.edu.sg
Password:
Creating application: wordpress2 in opensauce9005
Now your new domain name is being propagated worldwide (this might take a minute)...
retry # 6 - Waiting for DNS: wordpress2-opensauce9005.rhcloud.com
Cleaning up application
/usr/lib/ruby/gems/1.8/gems/rhc-0.92.11/lib/rhc-common.rb:519:in `sleep': Interrupt
from /usr/lib/ruby/gems/1.8/gems/rhc-0.92.11/lib/rhc-common.rb:519:in `create_app'
from /usr/lib/ruby/gems/1.8/gems/rhc-0.92.11/bin/rhc-app:226:in `create_app'
from /usr/lib/ruby/gems/1.8/gems/rhc-0.92.11/bin/rhc-app:565
from /usr/bin/rhc-app:23:in `load'
from /usr/bin/rhc-app:23
/usr/lib/ruby/gems/1.8/gems/rhc-0.92.11/bin/rhc:54:in `exit': no implicit conversion from nil to integer (TypeError)
from /usr/lib/ruby/gems/1.8/gems/rhc-0.92.11/bin/rhc:54
from /usr/bin/rhc:23:in `load'
from /usr/bin/rhc:23

The app create command timed out, and then threw errors.  I requested some environment information from the user, but please feel free to reach out for more details
Comment 1 Nam Duong 2012-05-18 14:13:49 EDT
FWIW, it's been tough to try to reproduce this, as I haven't been able to.  The user reported this during the same time:
https://openshift.redhat.com/community/forums/openshift/permission-denied-publickeygssapi-keyexgssapi-with-mic-with-win-7-0

where he/she was getting the following error on git clone (and ssh I suppose):
Permission denied (publickey,gssapi-keyex,gssapi-with-mic).
fatal: The remote end hung up unexpectedly

That may not be relevant since the app wasn't created (timeout), it didn't get to the clone part, but food for thought.
Comment 2 John (J5) Palmieri 2012-05-29 16:15:27 EDT
So this is a case of the user hitting Ctrl-c multiple times which returns nil for exitstatus which we then try to exit with inside of rhc.  I have a fix that returns the correct exit code which will go in after review.

The application would have been cleaned up if the transaction did not complete which is why the user could not ssh into their app.
Comment 3 John (J5) Palmieri 2012-05-29 18:05:50 EDT
fixed
Comment 4 Shirley Zhou 2012-05-30 02:23:05 EDT
Reproduce this bug with rhc-0.92.11-1.el6_2.noarch for continue 5times using following steps:

1. # rhc app create -a word -t php-5.3 -l szhou@redhat.com -p redhat -d --timeout 6 -n

2. Before  step 1 finish, type Ctrl+c when creating process at point as following 

######
Now your new domain name is being propagated worldwide (this might take a minute)...
    retry # 1 - Waiting for DNS: word-szhou.rhcloud.com^CCleaning up application


3. Then get message as following:
Exit Code: 0
broker_c: namespacerhloginsshapp_uuiddebugaltercartridgecart_typeactionapp_nameapi
api_c: placeholder
API version:    1.1.3
DEBUG: 'word' creation returned success.
Now your new domain name is being propagated worldwide (this might take a minute)...
    retry # 1 - Waiting for DNS: word-szhou.rhcloud.com^CCleaning up application
Contacting https://openshift.redhat.com
/usr/lib/ruby/gems/1.8/gems/rhc-0.92.11/lib/rhc-common.rb:519:in `sleep': Interrupt
	from /usr/lib/ruby/gems/1.8/gems/rhc-0.92.11/lib/rhc-common.rb:519:in `create_app'
	from /usr/lib/ruby/gems/1.8/gems/rhc-0.92.11/bin/rhc-app:226:in `create_app'
	from /usr/lib/ruby/gems/1.8/gems/rhc-0.92.11/bin/rhc-app:565
	from /usr/bin/rhc-app:19:in `load'
	from /usr/bin/rhc-app:19
/usr/lib/ruby/gems/1.8/gems/rhc-0.92.11/bin/rhc:54:in `exit': no implicit conversion from nil to integer (TypeError)
	from /usr/lib/ruby/gems/1.8/gems/rhc-0.92.11/bin/rhc:54
	from /usr/bin/rhc:19:in `load'
	from /usr/bin/rhc:19

Verify this bug with rhc-0.93.15-1.el6_2.noarch.rpm using same reproduce steps for 5 times, get message as following:
Exit Code: 0
broker_c: namespacerhloginsshapp_uuiddebugaltercartridgecart_typeactionapp_nameapi
api_c: placeholder
API version:    1.1.3
DEBUG: 'word' creation returned success.
Now your new domain name is being propagated worldwide (this might take a minute)...
    retry # 1 - Waiting for DNS: word-szhou.rhcloud.com^CCleaning up application
Contacting https://openshift.redhat.com
/usr/lib/ruby/gems/1.8/gems/rhc-0.93.15/lib/rhc-common.rb:576:in `sleep': Interrupt
	from /usr/lib/ruby/gems/1.8/gems/rhc-0.93.15/lib/rhc-common.rb:576:in `create_app'
	from /usr/lib/ruby/gems/1.8/gems/rhc-0.93.15/bin/rhc-app:227:in `create_app'
	from /usr/lib/ruby/gems/1.8/gems/rhc-0.93.15/bin/rhc-app:499
	from /usr/bin/rhc-app:19:in `load'
	from /usr/bin/rhc-app:19

TypeError disappear. So I think this bug has been fixed. I will change bug to Verified status.

Please notify me if you think need further testing. Thanks.

Note You need to log in before you can comment on or make changes to this bug.