This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 82301 - make panel stuff use icon theme instead of hardcoded path
make panel stuff use icon theme instead of hardcoded path
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gnome-panel (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
: GraphicArt, Triaged
Depends On:
Blocks: 79578
  Show dependency treegraph
 
Reported: 2003-01-20 22:43 EST by Tammy Fox
Modified: 2008-05-01 11:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-28 17:52:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tammy Fox 2003-01-20 22:43:44 EST
If I select Add to Panel => Button => "Anything" to add that button
to my panel, the icons are blurry -- it looks like it is scaling the smaller
version of the icons.
Comment 1 Havoc Pennington 2003-01-28 13:55:42 EST
This bug is a dup I think. I'm not sure we diagnosed it yet, though.
Comment 2 Alexander Larsson 2003-01-29 06:26:16 EST
Its a dup of some bug where the icon is dragged from the menu.
The core problem is that the panel launchers keep the icon filename instead of
the icon name. This means only one size is ever used instead of the nearest size
in the theme,
Comment 3 Havoc Pennington 2003-02-03 18:18:31 EST
We need to fix main menu applet, volume applet, launchers, and logout/lock
buttons. Hopefully they share some code :-/
Comment 4 Havoc Pennington 2003-02-14 12:30:14 EST
It looks to me like these use stock icons instead of storing a filename; 
I think perhaps we just don't have the right size stock icon or something.
Comment 5 Havoc Pennington 2003-02-19 17:40:06 EST
OK, I have a panel patch. However now blocking on graphic art; 
Garrett you'll need to make a 48x48/apps icon for 
all the panel icons in 24x24/stock/panel-*

bug #84576 and bug #84602 (cursor issues) are higher priority 
IMO. redhat-artwork will probably be rebuilt for the last time 
on Friday, so we need everything by then.
Comment 6 Havoc Pennington 2003-02-20 18:01:21 EST
2.2.0.1-6 fixes panel aspect, redhat-artwork updates will fix the other bit. 
Hopefully.
Comment 7 Havoc Pennington 2003-02-24 18:20:05 EST
redhat-artwork 0.71 should fix.
Comment 8 Bill Nottingham 2003-07-28 17:52:44 EDT
Closing some bugs that have been in MODIFIED for a while. Please reopen if the
problem persists.

Note You need to log in before you can comment on or make changes to this bug.