Bug 823021 - After updating the vim, the command crontab-e doesn't work anymore
After updating the vim, the command crontab-e doesn't work anymore
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
16
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Karsten Hopp
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-18 15:36 EDT by Volnei
Modified: 2012-06-16 08:05 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-15 19:49:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Volnei 2012-05-18 15:36:42 EDT
Description of problem:

After updating the vim, the command crontab-e doesn't work anymore

[root @ vmsmb01 operating] # crontab-e
/ bin / sh: / bin / vi: No such file or directory not found
crontab: "/ bin / vi" exited with status 127

Version-Release number of selected component (if applicable):


How reproducible:

Update vim to:
vim-filesystem-7.3.515-1.fc16.x86_64
vim-minimal-7.3.515-1.fc16.x86_64
vim-common-7.3.515-1.fc16.x86_64
vim-enhanced-7.3.515-1.fc16.x86_64

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Before update: 

ls /bin
-rwxr-xr-x. 1 root root 782024 Set 21  2011 vi


after updating the file 'vi' doesn't exist

Thanks
Comment 1 Frank Murphy 2012-05-22 03:22:14 EDT
Simple fix:
ln -s /usr/bin/vi /bin/vi

which would fit in with the whole converfs in F17+
Comment 2 Volnei 2012-05-22 07:04:37 EDT
I know that. 
However I think an update cannot corrupt another program.
Particularly given the importance of crontab
Comment 3 Frank Murphy 2012-05-22 07:30:06 EDT
(In reply to comment #2)
> I know that. 
> However I think an update cannot corrupt another program.
> Particularly given the importance of crontab


I agree, it was probbably just a build error.
As yum whatprovides */vi shows:
2:vim-minimal-7.3.515-1.fc16.x86_64 : A minimal version of the VIM editor
Repo        : @fedora-updates
Matched from:
Filename    : /usr/bin/vi
Filename    : /bin/vi


But if you go to koji:
the symlink is absent:
http://koji.fedoraproject.org/koji/rpminfo?rpmID=3103305
Comment 4 Volnei 2012-05-22 08:22:41 EDT
Yes, apparently it was an error building the package and can be easily fixed.

But it may cause some discomfort for some users. This will do.

Thanks
Comment 5 Fedora Update System 2012-05-23 05:51:00 EDT
vim-7.3.515-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/vim-7.3.515-2.fc16
Comment 6 Volnei 2012-05-23 14:37:34 EDT
Thanks for now.
Comment 7 Fedora Update System 2012-05-24 19:57:57 EDT
Package vim-7.3.515-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing vim-7.3.515-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8354/vim-7.3.515-2.fc16
then log in and leave karma (feedback).
Comment 8 John Mellor 2012-05-25 19:14:15 EDT
+0 karma.  Needs work.

Packaging error:
    yum update vim
fails, due to a missed dependency change: a move of /bin/ex from vim-minimal to vim-enhanced package.  So the only way to get this installed in F16 is to do:
    yum update vim-filesystem vim-minimal vim-common vim-enhanced
and then it installs correctly.

This change fixes the problem with crontab -e.
Comment 9 Fedora Update System 2012-06-15 19:49:52 EDT
vim-7.3.515-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Volnei 2012-06-16 08:05:13 EDT
Hi,

This issue was solved.

After update of vim

ls -l /bin/vi*
-rwxr-xr-x 1 root root 781312 Mai 23 06:39 /bin/vi
lrwxrwxrwx 1 root root      2 Jun 16 08:55 /bin/view -> vi

Thanks people

Note You need to log in before you can comment on or make changes to this bug.