Bug 823030 - Limits on number of process not being set when * used in limits.conf
Limits on number of process not being set when * used in limits.conf
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pam (Show other bugs)
15
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-18 16:23 EDT by Joseph Shraibman
Modified: 2012-05-18 16:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-18 16:52:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joseph Shraibman 2012-05-18 16:23:02 EDT
Description of problem:
In limits.conf, this does not work:
*                -       nproc        9000                                                                                      This does:                                         
0:65535          -       nproc        9000                                                                                                                              


Version-Release number of selected component (if applicable):
1.1.5-5.fc15

Also occurs on CentOS 6.2 with package: pam-1.1.1-10.el6_2.1

How reproducible:
always

Steps to Reproduce:
1. Use ulimit -a to view your limit, or car /proc/$$/limits
2. Put in limits.conf: *                -       nproc        9000
3. Open new session.  Observe that there was no change
4. In previous line, replace * with 0:65535
5. Open new session, Observe that nproc is now set to 9000



Additional info:
https://www.centos.org/modules/newbb/viewtopic.php?topic_id=35462
http://bugs.centos.org/view.php?id=5137
Comment 1 Tomas Mraz 2012-05-18 16:52:28 EDT
That's because the default values set with the * entry is overriden in the limits.d/90-nproc.conf file. You have to edit the default entry there.

Note You need to log in before you can comment on or make changes to this bug.