Bug 823039 - SELinux is preventing /usr/lib64/xulrunner-2/plugin-container from 'open' accesses on the file pulse-shm-3373247644.
SELinux is preventing /usr/lib64/xulrunner-2/plugin-container from 'open' acc...
Status: CLOSED DUPLICATE of bug 822273
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-05-18 17:12 EDT by José Antonio
Modified: 2012-05-21 01:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-05-21 01:33:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description José Antonio 2012-05-18 17:12:01 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.4-5.fc17.x86_64
time:           Fri 18 May 2012 10:11:34 PM WEST

:SELinux is preventing /usr/lib64/xulrunner-2/plugin-container from 'open' accesses on the file pulse-shm-3373247644.
:*****  Plugin catchall (100. confidence) suggests  ***************************
:If you believe that plugin-container should be allowed open access on the pulse-shm-3373247644 file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:allow this access for now by executing:
:# grep plugin-containe /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                unconfined_u:object_r:tmpfs_t:s0
:Target Objects                pulse-shm-3373247644 [ file ]
:Source                        plugin-containe
:Source Path                   /usr/lib64/xulrunner-2/plugin-container
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           xulrunner-12.0-1.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-121.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.4-5.fc17.x86_64 #1 SMP Mon
:                              May 7 17:29:34 UTC 2012 x86_64 x86_64
:Alert Count                   36
:First Seen                    Thu 17 May 2012 01:54:45 AM WEST
:Last Seen                     Fri 18 May 2012 09:46:12 PM WEST
:Local ID                      524d7d94-3017-42ee-828e-190fc0cf2af5
:Raw Audit Messages
:type=AVC msg=audit(1337373972.778:150): avc:  denied  { open } for  pid=14739 comm="plugin-containe" name="pulse-shm-3373247644" dev="tmpfs" ino=168901 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:tmpfs_t:s0 tclass=file
:type=SYSCALL msg=audit(1337373972.778:150): arch=x86_64 syscall=open success=no exit=EACCES a0=7fff98419670 a1=a0000 a2=0 a3=7fff98419400 items=0 ppid=31240 pid=14739 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=2 comm=plugin-containe exe=/usr/lib64/xulrunner-2/plugin-container subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:Hash: plugin-containe,mozilla_plugin_t,tmpfs_t,file,open
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
Comment 1 Miroslav Grepl 2012-05-21 01:33:38 EDT

*** This bug has been marked as a duplicate of bug 822273 ***

Note You need to log in before you can comment on or make changes to this bug.