Bug 823132 - Need a mkdir(1) -p like functionality in code.
Need a mkdir(1) -p like functionality in code.
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: core (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: krishnan parthasarathi
Raghavendra Bhat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-19 07:05 EDT by krishnan parthasarathi
Modified: 2015-11-03 18:04 EST (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 14:00:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description krishnan parthasarathi 2012-05-19 07:05:39 EDT
Description of problem:
Currently for creating directory at a given 'path' we only go as far as creating the last component of the 'path' if missing. This was a stop gap arrangement in place of full fledged mkdir(1) -p like functionality.
In fact in glusterd-rebalance.c, we have taken the approach of calling mkdir(1) utility for this. To avoid spawning a new process for the above or settling with an 'incomplete' solution, it would be good to have a C wrapper for mkdir(1) -p functionality in codebase.

Version-Release number of selected component (if applicable):


How reproducible:
N/A

Steps to Reproduce:
1.
2.
3.
  
Actual results:
N/A

Expected results:
N/A

Additional info:
This bug is meant to track the code changes that are necessary as described.
Comment 1 krishnan parthasarathi 2012-05-19 07:28:45 EDT
http://review.gluster.com/3347 fixes this bug. (Gerrit's auto update didnt happen since the fix's merge raced bug creation :) )
Comment 2 krishnan parthasarathi 2012-05-22 05:32:35 EDT
http://review.gluster.com/3378 simplifies the interface introduced in the commit mentioned in previous comment.

Note You need to log in before you can comment on or make changes to this bug.