Bug 82316 - #79218 - Spanish translation missing for desktop menu
#79218 - Spanish translation missing for desktop menu
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-printer (Show other bugs)
phoebe
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
: 84362 (view as bug list)
Depends On:
Blocks: 79579
  Show dependency treegraph
 
Reported: 2003-01-21 02:31 EST by Paul Gampe
Modified: 2013-01-10 16:33 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-01 07:40:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to use intltool (4.72 KB, patch)
2003-03-19 08:00 EST, Miloslav Trmac
no flags Details | Diff

  None (edit)
Description Paul Gampe 2003-01-21 02:31:08 EST
Description of problem: 
The desktop menu entry for redhat-config-printer is not translated, as reported in #79218. 
 
 
Version-Release number of selected component (if applicable): 
 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1. Install es_ES locale 
2. Login to desktop 
3. 
     
Actual results: 
English menu item 
 
Expected results: 
Spanish translation 
 
Additional info: 
I could not find the desktop item for translation on elvis .
Comment 1 Tim Waugh 2003-01-21 06:49:31 EST
It's in printconf/printconf-gui.desktop.
Comment 2 Tim Waugh 2003-01-27 08:54:53 EST
Let me know what I need to do here.
Comment 3 Paul Gampe 2003-01-28 02:07:21 EST
Hi Tim, you could use the intltool* set to extract the .desktop strings and put them into the .po 
files for translation, or look through the strings in the .po files to see if translations for them 
already exist that you could c'n'p into the .desktop file. 
Comment 4 Tim Waugh 2003-01-28 07:33:09 EST
Patch from bug #79745 was broken.  Should be fixed in
redhat-config-printer-0.6.42-1.  Please confirm.
Comment 5 Tim Waugh 2003-01-28 07:33:59 EST
Oops, that was intended for a different bug.
Comment 6 Tim Waugh 2003-02-14 18:57:50 EST
*** Bug 84362 has been marked as a duplicate of this bug. ***
Comment 7 Tim Waugh 2003-03-04 11:45:55 EST
Not sure how to use intltool*.  Any examples I could look at elsewhere?
Comment 8 Miloslav Trmac 2003-03-19 08:00:51 EST
Created attachment 90662 [details]
Patch to use intltool

Hello,
Usually, intltool is used together with autoconf; intltoolize is run from
autogen.sh and the distributed tarball contains intltool-*.in, which are
converted to intltool-* by configure. This means that the tarball is not
dependent on whether does the user have intltool installed.

This is not much of a concern for printconf ;-), so the attached patch
just calls /usr/bin/intltool-*. It just converts the system to use intltool
and makes the printconf-gui.desktop file translatable. After building the
original package and package with this patch applied, there are no differences
in *.py or *.mo files.

(It also fixes a typo in the Makefile: verison -> version)

* You'll need to add intltool to Buildrequires: in printconf.spec
* This patch does not include the regenerated *.po{,t} files. After running
  make -C po update-po, you should get a new set which has all the strings
  the original files had, plus about 30 new strings. Two of them come from
  printconf-gui.desktop.in and should be translated (or merged from previous
  file, see below).
  
  The others are caused by the
  fact that *.py files contain _N() markers, which were not found using the
  previous xgettext invocation. It seems most of the markers should not be
  there (definitely the _N('') ) at all.
* printconf-gui.desktop is generated from printconf-gui.desktop.in
  by intltool-merge. The old translations from printconf-gui.desktop
  were REMOVED and will have to be manually merged to newly generated *.po
  files.
* This should also fix your libglade-xgettext problems, intltool supports
  *.glade natively. I have added gui/redhat-config-printer.glade in POTFILES
  and removed the commented-out rule for redhat-config-printer.glade.str.
Comment 9 Tim Waugh 2003-04-01 07:40:42 EST
Thanks a lot!  Patch applied in redhat-config-printer-0.6.50-1.

Note You need to log in before you can comment on or make changes to this bug.