Bug 823176 - Line numbers in file annotation are not in sync with the actual lines.
Line numbers in file annotation are not in sync with the actual lines.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qgit (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Horák
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-19 14:29 EDT by Elbin Pallimalil
Modified: 2012-10-02 04:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-20 16:33:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (310.24 KB, image/png)
2012-05-19 14:32 EDT, Elbin Pallimalil
no flags Details
Proposed fix (754 bytes, patch)
2012-09-13 16:56 EDT, vaxon
no flags Details | Diff

  None (edit)
Description Elbin Pallimalil 2012-05-19 14:29:19 EDT
Description of problem:
Please refer the attached screen shot. When viewing a file the line numbers in the file annotation section are not in sync with the actual line numbers. For eg in the screen shot, line number 15 is shown against what is actually line number 16.


Version-Release number of selected component (if applicable):
2.3


How reproducible:
Always


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Elbin Pallimalil 2012-05-19 14:32:07 EDT
Created attachment 585598 [details]
Screenshot
Comment 2 Dan Horák 2012-05-22 04:30:15 EDT
I think there is a problem with fonts setup in the application and in the system. Please open a bug report in upstream directly at http://libre.tibirna.org/projects/qgit
Comment 3 Elbin Pallimalil 2012-06-05 09:44:22 EDT
Bug opened.

http://libre.tibirna.org/issues/20
Comment 4 Jim Lieb 2012-06-12 18:54:28 EDT
I've tried all the combos of monospace fonts I could find.  It is not an issue of fonts setup.  The problem is in how the file display and file annotation is set up.  Choosing a magic font "works" only if the font metrics are somehow identical with all font features.  The annotations and line numbers are in a shaded (grey) font and the file itself is black.  Whatever goes on in the rendering of each whether it is rounding errors, aliasing funnies or ??? getting the right magic is just dumb luck.

To show how bad it is off, If I display a 1233 line file, that last line is somewhere between lines 1164 and 1165 in the annotations/line numbers column.  This makes this very useful feature (nicer than gitk et al) useless.

This feature needs to be re-thought.  What needs to be done is to replace this canvas, text box, or whatever widget it is with a "table". I may not be using the right terms but this pane has to be a two/three column, N row table. The rendering will then be rendering cells and who cares what the font characteristics are.

Elbin, I checked out issue 20 over on their site and the analysis is close but missing what I noted above.  I don't have an acct there so could you poke them and pass this on?  It is annoying enough that i'd fix it myself except I'm up to my ears in getting an nfs server to work.

Thanks
Comment 5 vaxon 2012-09-13 16:56:40 EDT
Created attachment 612641 [details]
Proposed fix

Could you, please, test this patch. It seems to work for me on fedora 17.

Thanks,
Val.
Comment 6 Dan Horák 2012-09-14 02:57:51 EDT
(In reply to comment #5)
> Created attachment 612641 [details]
> Proposed fix
> 
> Could you, please, test this patch. It seems to work for me on fedora 17.
> 
> Thanks,
> Val.

Many thanks, it fixes the issue also for me, going to prepare an official update.
Comment 7 Fedora Update System 2012-09-14 03:18:47 EDT
qgit-2.4-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/qgit-2.4-4.fc16
Comment 8 Fedora Update System 2012-09-14 03:18:58 EDT
qgit-2.4-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/qgit-2.4-4.fc18
Comment 9 Fedora Update System 2012-09-14 03:19:11 EDT
qgit-2.4-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/qgit-2.4-4.fc17
Comment 10 Fedora Update System 2012-09-14 03:19:21 EDT
qgit-2.4-4.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/qgit-2.4-4.el6
Comment 11 Fedora Update System 2012-09-16 13:10:19 EDT
Package qgit-2.4-4.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qgit-2.4-4.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13947/qgit-2.4-4.fc18
then log in and leave karma (feedback).
Comment 12 Jim Lieb 2012-09-19 12:43:40 EDT
Tested 2.4-4.fc16.x86_64.  Works.  I'm ok with closing this.
Comment 13 Fedora Update System 2012-09-20 16:33:46 EDT
qgit-2.4-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 vaxon 2012-09-29 08:20:02 EDT
Will the f16/f17/el6 versions hit the stable repo like f18 did?

Thanks,
Val.
Comment 15 Dan Horák 2012-10-02 04:03:17 EDT
(In reply to comment #14)
> Will the f16/f17/el6 versions hit the stable repo like f18 did?
> 
> Thanks,
> Val.

All should out now, thanks for reminder.

Note You need to log in before you can comment on or make changes to this bug.