This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 823205 - EXT4_fs warning (device-dm0): ext4_end_bio:250: I/O error writing to inode (offset: xxxx size xxxx starting block xxxx)
EXT4_fs warning (device-dm0): ext4_end_bio:250: I/O error writing to inode (o...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Eric Sandeen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-19 18:58 EDT by Joshua Covington
Modified: 2012-05-25 13:48 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-24 11:41:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
3x screenshots (560.97 KB, application/zip)
2012-05-19 18:58 EDT, Joshua Covington
no flags Details

  None (edit)
Description Joshua Covington 2012-05-19 18:58:59 EDT
Created attachment 585610 [details]
3x screenshots

Description of problem:
When trying to install big packages (usually > 100MB) on a livecd system I get this error and the only way to continue is to hardware reset the system. This is reproducable in a kvm.

The livecd is a custom livecd-image with size=10GB so that it has enough space to incorporate any updates. The live-system usually has about 6,5GB free space on /. This is on a machine with 16GB ram memory so that avaiable physical memory shouldn't be a problem.

The problem started to appear in the last 3-4 weeks and is not specific to 3.3.6 kernel or fc16.

Version-Release number of selected component (if applicable):
kernel-3.3.6-1.fc16.x86_64

How reproducible:
run any livecd-image and try to install libreoffice for instance. A message "input/output Buffer" will appear and in my case the dmesg log is full of "EXT4_fs warning (device-dm0): ext4_end_bio:250: I/O error witing to inode (offset: xxxx size xxxx starting block xxxx)"

Steps to Reproduce:
1. see above
2.
3.
  
Actual results:
Since enough physical memory is available I don't see why my filesystem should reach its limit.

Expected results:
Install as many packages as memery is available.

Additional info:
See attached screenshots (in a zip file) for the exact error message.
Comment 1 Dave Jones 2012-05-24 11:05:37 EDT
what is the backing device that dm-0 is on ?  Any possibility of media errors ?
Comment 2 Eric Sandeen 2012-05-24 11:34:02 EDT
You are still running the livecd I guess?  (this isn't a livecd-installed-to-HD system right?)

Can you go to a terminal and type "dmesg" and attach the output here (much better than screenshots if possible....)
Comment 3 Eric Sandeen 2012-05-24 11:41:49 EDT
Actually the first line of the first png says it all:

"device-mapper: snapshots: invalidating snapshot: Unable to allocate exception"

you ran out of snapshot exception space.  This isn't a kernel bug at all, and it may not be _any_ bug at all.  I don't know how the exception store is set up on a livecd, but you simply ran out of space.

Please investigate the devicemapper setup within the livecd, and if you feel that something is misconfigured to not make optimal use of your memory for dm snapshot purposes, I'd open a bug with anaconda.

Thanks,
-Eric
Comment 4 Joshua Covington 2012-05-25 13:48:14 EDT
Yes, this is a livecd, not a livecd-installed-to-HD system.

I know that I ran out of space but with a 10GB root partition (set in the kickstart file when creating the livecd) and 16GB ram memory this should not happen. I'll post this on the livecd-list.

Note You need to log in before you can comment on or make changes to this bug.