Bug 823210 - SELinux is preventing /usr/libexec/gstreamer-0.10/gst-plugin-scanner from using the 'dac_override' capabilities.
SELinux is preventing /usr/libexec/gstreamer-0.10/gst-plugin-scanner from usi...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:36ffed17a1164879967def1535c...
:
: 909615 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-19 19:25 EDT by hellojoker
Modified: 2013-02-11 07:49 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-24 10:00:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hellojoker 2012-05-19 19:25:04 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.4-5.fc17.x86_64
time:           dom 20 mag 2012 01:24:43 CEST

description:
:SELinux is preventing /usr/libexec/gstreamer-0.10/gst-plugin-scanner from using the 'dac_override' capabilities.
:
:*****  Plugin dac_override (91.4 confidence) suggests  ***********************
:
:If si vuole aiutare ad identificare se al dominio serva questo accesso o se si possiede un file con i permessi sbagliati sul sistema
:Then attivare l'auditing completo per ottenere le informazioni del percorso del file incriminato e generare nuovamente l'errore.
:Do
:
:Abilitare l'auditing completo
:# auditctl -w /etc/shadow -p w
:Provare a rigenerare AVC. Quindi eseguire
:# ausearch -m avc -ts recent
:Se si vede il campo PATH controllare il proprietario/permessi del file, quindi aggiustarlo, 
:altrimenti inviare il bug a bugzilla.
:
:*****  Plugin catchall (9.59 confidence) suggests  ***************************
:
:If si pensa che gst-plugin-scanner dovrebbe avere funzionalità dac_override in modo predefinito.
:Then si dovrebbe riportare il problema come bug.
:E' possibile generare un modulo di politica locale per consentire questo accesso.
:Do
:consentire questo accesso per il momento eseguendo:
:# grep gst-plugin-scan /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
:Target Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
:Target Objects                 [ capability ]
:Source                        gst-plugin-scan
:Source Path                   /usr/libexec/gstreamer-0.10/gst-plugin-scanner
:Port                          <Sconosciuto>
:Host                          (removed)
:Source RPM Packages           totem-3.4.1-3.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-121.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.4-5.fc17.x86_64 #1 SMP Mon May 7
:                              17:29:34 UTC 2012 x86_64 x86_64
:Alert Count                   19
:First Seen                    dom 20 mag 2012 01:22:54 CEST
:Last Seen                     dom 20 mag 2012 01:23:27 CEST
:Local ID                      40c1c453-c004-4930-b7df-209219576141
:
:Raw Audit Messages
:type=AVC msg=audit(1337469807.251:184): avc:  denied  { dac_override } for  pid=2457 comm="totem-video-thu" capability=1  scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tclass=capability
:
:
:type=AVC msg=audit(1337469807.251:184): avc:  denied  { dac_read_search } for  pid=2457 comm="totem-video-thu" capability=2  scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tclass=capability
:
:
:type=SYSCALL msg=audit(1337469807.251:184): arch=x86_64 syscall=open success=no exit=EACCES a0=f0a500 a1=0 a2=0 a3=88 items=0 ppid=2216 pid=2457 auid=1000 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=pts0 ses=2 comm=totem-video-thu exe=/usr/bin/totem-video-thumbnailer subj=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 key=(null)
:
:Hash: gst-plugin-scan,thumb_t,thumb_t,capability,dac_override
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-05-21 04:27:30 EDT
Did you log in as root?
Comment 2 hellojoker 2012-05-22 21:11:05 EDT
First of all I apologize for my English.

Did you log in as root?

I had a video on a partition that I wanted to play, with nautilus could mount the partition, but I could not have access to the user folder with the file. To avoid this problem, I gave beesu nautilus from the terminal, after I started the video with totem.

:)

ps -au | grep totem 
root      7706  9.0  3.1 1526204 65504 pts/0   Sl+  03:04   0:11 totem /var/run/media/....
Comment 3 Daniel Walsh 2012-05-24 10:00:59 EDT
Well you should have changed the ownership on the video.  This is not an access that we want to allow.
Comment 4 Miroslav Grepl 2013-02-11 07:49:39 EST
*** Bug 909615 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.