Bug 823240 - installation fails
installation fails
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-20 04:38 EDT by Need Real Name
Modified: 2012-07-16 19:51 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-16 19:51:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs attached (16.79 KB, application/zip)
2012-05-23 13:36 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2012-05-20 04:38:24 EDT
Installation of F16, F17beta, etc DVD randomly fails.
The problem is in repository.
anaconda tries to access repository at https://.... URL
The problem is than not all mirrors work at https://...

A workaround is to edit repository list 
and replace https:// by http:// 
then installation goes OK. 

Just make sure that all mirrors support https://
or, another option, replace https:// by http://

As it stays now - installation randomly fails 
depending on what repository mirror is used.
Comment 1 Chris Lumens 2012-05-23 10:14:11 EDT
Please attach the complete /tmp/anaconda.log to this bug report.  Thanks.
Comment 2 Need Real Name 2012-05-23 13:36:28 EDT
Created attachment 586419 [details]
logs attached

Logs attached, but they are irrelevant. 
As I stated before - if a mirror does not support 
https:// installation would fail
and not try a different mirror
Comment 3 Need Real Name 2012-05-26 04:41:36 EDT
And may be original site was down.
It periodically fails.

 yum -y update
Loaded plugins: langpacks, presto, refresh-packagekit
Could not get metalink https://mirrors.fedoraproject.org/metalink?repo=updates-released-f17&arch=x86_64 error was
14: HTTP Error 503 - Service Unavailable : https://mirrors.fedoraproject.org/metalink?repo=updates-released-f17&arch=x86_64
No Packages marked for Update

2 seconds later
 yum -y update
Loaded plugins: langpacks, presto, refresh-packagekit
No Packages marked for Update
Comment 4 Jesse Keating 2012-07-16 19:51:40 EDT
So the mirror does support it, but occasionally has too many connections or some other reason for rejecting.  We can't do much about that.

Note You need to log in before you can comment on or make changes to this bug.