Bug 823248 - [ovirt] [vdsm] exception in getVdsCaps in case bridge is renamed and vdsm is not resarted
[ovirt] [vdsm] exception in getVdsCaps in case bridge is renamed and vdsm is ...
Status: CLOSED DUPLICATE of bug 840594
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm (Show other bugs)
6.3
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Dan Kenigsberg
Haim
infra, network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-20 06:52 EDT by Haim
Modified: 2014-01-12 19:52 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-07 04:31:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Haim 2012-05-20 06:52:02 EDT
Description of problem:

- host is operational configured with bridge name = rhevm (name is not important)
- renamed bridge name from rhevm to ovirtmgmt
- restart network service 
- vdsm fails to respond to getVdsCaps and fails with nasty exception:  


Thread-870::DEBUG::2012-05-20 13:21:43,327::BindingXMLRPC::849::vds::(wrapper) client [10.35.97.174]::call getCapabilities with () {}
Thread-870::ERROR::2012-05-20 13:21:43,335::BindingXMLRPC::864::vds::(wrapper) unexpected error
Traceback (most recent call last):
  File "/usr/share/vdsm/BindingXMLRPC.py", line 854, in wrapper
    res = f(*args, **kwargs)
  File "/usr/share/vdsm/BindingXMLRPC.py", line 263, in getCapabilities
    ret = api.getCapabilities()
  File "/usr/share/vdsm/API.py", line 1075, in getCapabilities
    c = caps.get()
  File "/usr/share/vdsm/caps.py", line 225, in get
    caps.update(netinfo.get())
  File "/usr/lib/python2.6/site-packages/vdsm/netinfo.py", line 243, in get
    d['networks'][netname] = { 'ports': ports(netname),
  File "/usr/lib/python2.6/site-packages/vdsm/netinfo.py", line 92, in ports
    return os.listdir('/sys/class/net/' + bridge + '/brif')
OSError: [Errno 2] No such file or directory: '/sys/class/net/rhevm/brif'


mitigation: restart vdsm service
Comment 1 Haim 2012-05-20 06:53:18 EDT
latest vdsm on master: f43fb7de2c3fd24f0520b7f444a3318ef28cc915
Comment 2 Dan Kenigsberg 2012-08-01 09:47:53 EDT
Yep, if `virsh net-list` show a bridged vdsm network without an actual bridge implementation, we're in trouble.

Since it was open by Red Hat QE and affecting RHEV, moving the tracking downstream.
Comment 4 lpeer 2012-08-07 04:31:11 EDT

*** This bug has been marked as a duplicate of bug 840594 ***

Note You need to log in before you can comment on or make changes to this bug.