Bug 823261 - F16 to F17 upgrade using preupgrade pulled in spare 32-bit (i686) packeges
F16 to F17 upgrade using preupgrade pulled in spare 32-bit (i686) packeges
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-20 07:46 EDT by Tomas Toth
Modified: 2013-07-31 20:40 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-31 20:40:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/root/upgrade.log (92.39 KB, text/plain)
2012-05-20 07:50 EDT, Tomas Toth
no flags Details

  None (edit)
Description Tomas Toth 2012-05-20 07:46:35 EDT
Description of problem:
I upgraded my F16 system to F17 using preupgrade yesterday (2012-05-19).
No 32-bit (*.i[3-6]86) package was present in F16.
After the upgrade I discovered that the following 32-bit packages got pulled in:

audit-libs.i686           2.2.1-1.fc17        @anaconda-0     
cracklib.i686             2.8.18-3.fc17       @anaconda-0     
cryptsetup-libs.i686      1.4.2-1.fc17        @anaconda-0     
db4.i686                  4.8.30-10.fc17      @anaconda-0     
dbus-libs.i686            1:1.4.10-4.fc17     @anaconda-0     
device-mapper-libs.i686   1.02.74-6.fc17      @anaconda-0     
elfutils-libelf.i686      0.153-2.fc17        @anaconda-0     
expat.i686                2.1.0-1.fc17        @anaconda-0     
gamin.i686                0.1.10-12.fc17      @anaconda-0     
glib2.i686                2.32.1-1.fc17       @anaconda-0     
glibc.i686                2.15-37.fc17        @anaconda-0     
kmod-libs.i686            7-1.fc17	      @anaconda-0     
libacl.i686               2.2.51-5.fc17       @anaconda-0     
libattr.i686              2.4.46-5.fc17       @anaconda-0     
libcap.i686               2.22-2.fc17	      @anaconda-0     
libffi.i686               3.0.10-2.fc17       @anaconda-0     
libgcrypt.i686            1.5.0-3.fc17        @anaconda-0     
libgpg-error.i686         1.10-2.fc17	      @anaconda-0     
libselinux.i686           2.1.10-3.fc17       @anaconda-0     
libsepol.i686             2.1.5-3.fc17        @anaconda-0     
libudev.i686              182-1.fc17	      @anaconda-0     
libuuid.i686              2.21.1-1.fc17       @anaconda-0     
nss-softokn-freebl.i686   3.13.4-2.fc17       @anaconda-0     
pam.i686                  1.1.5-5.fc17        @anaconda-0     
polkit.i686               0.104-6.fc17        @anaconda-0     
systemd.i686              44-8.fc17	      @anaconda-0     
tcp_wrappers-libs.i686    7.6-69.fc17	      @anaconda-0     
xz-libs.i686              5.1.1-2alpha.fc17   @anaconda-0     
zlib.i686                 1.2.5-6.fc17        @anaconda-0     

Each of the above packages has its 64-bit (x86_64) version installed too with the same version.

Note: 
The F16 was upgraded from F15 also by preuprade sometime Dec 2011.
The F16 was up to date.


Version-Release number of selected component (if applicable):
Whatever the preupgrade downloaded yesterday (2012-05-19).


How reproducible:
I could upgrade only once, I did not create an image of the original F16 to be able to get back to it.


Steps to Reproduce:
On F16:
  yum update
  preupgrade

  
Actual results:
32-bit packages present.

Expected results:
No 32-bit package.


Additional info:
I am goig to attach the upgrade.log as soon as I find out how to do it in the new BZ.
I have the list of installed F16 packages too, let me know if the list can help.

Can I remove these .i686 packages without harming my system?

The issue is not blocking but why wasting disk space and lengthen updates needlessly.
Comment 1 Tomas Toth 2012-05-20 07:50:06 EDT
Created attachment 585630 [details]
/root/upgrade.log
Comment 2 Tomas Toth 2012-05-26 06:58:58 EDT
F16 preupgrade version:
preupgrade.noarch    1.1.10-1.fc16

I removed the above 32-bit (.i686) packages as they did not removed any dependency. No issues yet.
Comment 3 gatlibs 2012-06-30 19:21:16 EDT
I had a similar issue. I have had many packages from anaconda-0. I tried to use preupgrade, but it was too slow in downloading. I used the D.V.D. to upgrade. It failed at grub. I tried both options. It hung. I rebooted to my on-disc fedora. I finished upgrading there. It was weird, but worked, somehow... I now, occasionally, weed through these anaconda-0 packages because of problems of not upgrading or dependencies. I don't know how to list them all. I thought maybe "yum --disablerepo=* --enablerepo=anaconda-0 would work, but it didn't.
Comment 4 Fedora End Of Life 2013-07-03 18:39:29 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 5 Fedora End Of Life 2013-07-31 20:40:46 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.