Bug 823268 - SELinux is preventing /usr/libexec/totem-plugin-viewer from 'execute' accesses on the file /home/ydroneaud/.orc/orcexec.hWsvop (deleted).
SELinux is preventing /usr/libexec/totem-plugin-viewer from 'execute' accesse...
Status: CLOSED DUPLICATE of bug 823251
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:3cd3e7f209949c0ed4edd35a41f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-20 08:55 EDT by Yann Droneaud
Modified: 2012-05-21 10:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-21 10:06:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yann Droneaud 2012-05-20 08:55:14 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.4-5.fc17.x86_64
time:           dim. 20 mai 2012 14:54:57 CEST

description:
:SELinux is preventing /usr/libexec/totem-plugin-viewer from 'execute' accesses on the file /home/ydroneaud/.orc/orcexec.hWsvop (deleted).
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that totem-plugin-viewer should be allowed execute access on the orcexec.hWsvop (deleted) file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep multiqueue0:src /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                unconfined_u:object_r:gstreamer_home_t:s0
:Target Objects                /home/ydroneaud/.orc/orcexec.hWsvop (deleted) [
:                              file ]
:Source                        multiqueue0:src
:Source Path                   /usr/libexec/totem-plugin-viewer
:Port                          <Inconnu>
:Host                          (removed)
:Source RPM Packages           totem-mozplugin-3.4.1-3.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-121.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.4-4.fc17.x86_64 #1 SMP
:                              Fri May 4 17:25:07 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    dim. 13 mai 2012 15:04:04 CEST
:Last Seen                     dim. 13 mai 2012 15:04:04 CEST
:Local ID                      ce1196c4-3060-45e1-9c21-d93f7403a223
:
:Raw Audit Messages
:type=AVC msg=audit(1336914244.945:434): avc:  denied  { execute } for  pid=14608 comm="multiqueue0:src" path=2F686F6D652F7964726F6E656175642F2E6F72632F6F7263657865632E685773766F70202864656C6574656429 dev="dm-3" ino=131219 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:gstreamer_home_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1336914244.945:434): arch=x86_64 syscall=mmap success=no exit=EACCES a0=0 a1=10000 a2=5 a3=1 items=0 ppid=1 pid=14608 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=4 comm=multiqueue0:src exe=/usr/libexec/totem-plugin-viewer subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:
:Hash: multiqueue0:src,mozilla_plugin_t,gstreamer_home_t,file,execute
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Daniel Walsh 2012-05-21 10:06:20 EDT
Run restorecon -R -v ~/.org

Should fix the labels and stop the AVC's from happening.

*** This bug has been marked as a duplicate of bug 823251 ***

Note You need to log in before you can comment on or make changes to this bug.