Bug 823314 - [abrt] yum-3.4.3-23.fc17: optparse.py:1602:print_usage:UnicodeEncodeError: 'ascii' codec can't encode characters in position 64-73: ordinal not in range(128)
[abrt] yum-3.4.3-23.fc17: optparse.py:1602:print_usage:UnicodeEncodeError: 'a...
Status: CLOSED DUPLICATE of bug 819229
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
abrt_hash:99ddabea3d44a7dccade9a43f50...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-20 16:17 EDT by Ifrit
Modified: 2014-01-21 18:22 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-21 04:24:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: smolt_data (3.20 KB, text/plain)
2012-05-20 16:18 EDT, Ifrit
no flags Details

  None (edit)
Description Ifrit 2012-05-20 16:17:55 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
cmdline:        /usr/bin/python -t /usr/share/yum-cli/completion-helper.py -d 0 -C list available --disa
comment:        print in console 'yum --dis' and press TAB give this error
event_log:      2012-05-21-00:16:52> Smolt profile successfully saved
executable:     /usr/share/yum-cli/completion-helper.py
kernel:         3.3.6-3.fc17.i686
time:           Пн. 21 мая 2012 00:15:05
uid:            1000
username:       ifrit

smolt_data:     Binary file, 3279 bytes

backtrace:
:optparse.py:1602:print_usage:UnicodeEncodeError: 'ascii' codec can't encode characters in position 64-73: ordinal not in range(128)
:
:Traceback (most recent call last):
:  File "/usr/share/yum-cli/completion-helper.py", line 81, in <module>
:    main(sys.argv[1:])
:  File "/usr/share/yum-cli/completion-helper.py", line 75, in main
:    base.getOptionsConfig(args)
:  File "/usr/share/yum-cli/cli.py", line 287, in getOptionsConfig
:    (opts, self.cmds) = self.optparser.setupYumConfig(args=args)
:  File "/usr/share/yum-cli/cli.py", line 1903, in setupYumConfig
:    (opts, cmds) = self.parse_args(args=args)
:  File "/usr/lib/python2.7/optparse.py", line 1401, in parse_args
:    self.error(str(err))
:  File "/usr/share/yum-cli/cli.py", line 1853, in error
:    self.print_usage()
:  File "/usr/lib/python2.7/optparse.py", line 1602, in print_usage
:    print >>file, self.get_usage()
:UnicodeEncodeError: 'ascii' codec can't encode characters in position 64-73: ordinal not in range(128)
:
:Local variables in innermost frame:
:self: <cli.YumOptionParser instance at 0xb711706c>
:file: None
Comment 1 Ifrit 2012-05-20 16:18:00 EDT
Created attachment 585675 [details]
File: smolt_data
Comment 2 Zdeněk Pavlas 2012-05-21 04:24:55 EDT

*** This bug has been marked as a duplicate of bug 819229 ***

Note You need to log in before you can comment on or make changes to this bug.