Bug 823340 - Review Request: rubygem-ipaddress - rubygem abstraction for ipv4, ipv6 addresses
Review Request: rubygem-ipaddress - rubygem abstraction for ipv4, ipv6 addresses
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Scherer
Fedora Extras Quality Assurance
:
: 1166734 (view as bug list)
Depends On:
Blocks: 823344
  Show dependency treegraph
 
Reported: 2012-05-20 20:20 EDT by Jonas Courteau
Modified: 2015-01-23 23:59 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-11 18:19:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
misc: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Jonas Courteau 2012-05-20 20:20:26 EDT
Spec URL: https://raw.github.com/jcourteau/rubygems-rpms/master/fc17/rubygem-ipaddress/rubygem-ipaddress.spec
SRPM URL: http://rpms.courteau.org/fedora/rubygem-ipaddress-0.8.0-1.fc17.src.rpm

Description: IPAddress is a Ruby library designed to make manipulation
of IPv4 and IPv6 addresses both powerful and simple. It mantains
a layer of compatibility with Ruby's own IPAddr, while 
addressing many of its issues.


This is part of a set of dependencies for rubygem-chef.  I've got about 14 packages to add, all ruby gems, and am looking for a sponsor.  Several of the packages were previously in Fedora (F11 and F12), but were removed due to lack of a maintainer.
Comment 1 Michael Scherer 2012-12-15 15:47:10 EST
I will take this review, 

Package Review
==============

Key:
[x] = Pass
[!] = Fail
[-] = Not applicable
[?] = Not evaluated
[ ] = Manual review needed


Issues:
=======
- Gem package should exclude cached Gem. However, It seems to have disappeared from the ruby guidelines, but that's still present in the talk page :
https://fedoraproject.org/wiki/Packaging_talk:Ruby

So i am not sure exactly on what to do. Could you reach ruby-sig and check ? ( from what I have seen and read, there is more people who would prefer to have them removed than kept, since there isn't much reason to keep the cache but I didn't look much )

Except that, the package should be good.


===== MUST items =====

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: Package contains no bundled libraries without FESCO exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[x]: Development files must be in a -devel package
[x]: Package requires other packages for directories it uses.
[x]: Package uses nothing in %doc for runtime.
[x]: Package is not known to require ExcludeArch.
[x]: Package complies to the Packaging Guidelines
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses found:
     "Unknown or generated". 1 files have unknown license. Detailed output of
     licensecheck in /home/misc/checkout/git/FedoraReview/823340-rubygem-
     ipaddress/licensecheck.txt
[x]: License file installed when any subpackage combination is installed.
[x]: Package consistently uses macro is (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
     Note: Package contains no Conflicts: tag(s)
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: All build dependencies are listed in BuildRequires, except for any that
     are listed in the exceptions section of Packaging Guidelines.
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Each %files section contains %defattr if rpm < 4.4
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Fully versioned dependency in subpackages, if present.
[x]: Spec file lacks Packager, Vendor, PreReq tags.
[x]: If (and only if) the source package includes the text of the license(s)
     in its own file, then that file, containing the text of the license(s)
     for the package is included in %doc.
[x]: Package is named using only allowed ASCII characters.
[x]: Package do not use a name that already exist
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as provided
     in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Large documentation must go in a -doc subpackage.
     Note: Documentation size is 0 bytes in 0 files.
[x]: Packages must not store files under /srv, /opt or /usr/local
[x]: Package successfully compiles and builds into binary rpms on at least one
     supported primary architecture.
[x]: Package installs properly.
[x]: CheckResultdir
[x]: Rpmlint is run on all rpms the build produces.
     Note: No rpmlint messages.

Ruby:
[x]: Platform dependent files must all go under %{gem_extdir}, platform
     independent under %{gem_dir}.
[x]: Gem package must not define a non-gem subpackage
[x]: Gem package is named rubygem-%{gem_name}
[x]: Package contains BuildRequires: rubygems-devel.
[x]: Gem package must define %{gem_name} macro.
[x]: Pure Ruby package must be built as noarch
[x]: Package contains Requires: ruby(abi).

===== SHOULD items =====

Generic:
[-]: If the source package does not include license text(s) as a separate file
     from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (rpm -q --provides and rpm -q
     --requires).
[x]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[x]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed files.
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: Dist tag is present.
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: SourceX tarball generation or download is documented.
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define.

Ruby:
[!]: Gem package should exclude cached Gem.
[x]: Test suite of the library should be run.

===== EXTRA items =====

Generic:
[x]: Large data in /usr/share should live in a noarch subpackage if package is
     arched.
[x]: Rpmlint is run on all installed packages.
     Note: No rpmlint messages.
[x]: Spec file according to URL is the same as in SRPM.


Rpmlint
-------
Checking: rubygem-ipaddress-0.8.0-1.fc18.noarch.rpm
          rubygem-ipaddress-doc-0.8.0-1.fc18.noarch.rpm
2 packages and 0 specfiles checked; 0 errors, 0 warnings.




Rpmlint (installed packages)
----------------------------
# rpmlint rubygem-ipaddress rubygem-ipaddress-doc
2 packages and 0 specfiles checked; 0 errors, 0 warnings.
# echo 'rpmlint-done:'



Requires
--------
rubygem-ipaddress (rpmlib, GLIBC filtered):
    ruby
    ruby(abi)
    ruby(rubygems)

rubygem-ipaddress-doc (rpmlib, GLIBC filtered):
    rubygem-ipaddress



Provides
--------
rubygem-ipaddress:
    rubygem(ipaddress)
    rubygem-ipaddress

rubygem-ipaddress-doc:
    rubygem-ipaddress-doc



MD5-sum check
-------------
http://rubygems.org/gems/ipaddress-0.8.0.gem :
  CHECKSUM(SHA256) this package     : 398ac94becdbce3151acc8bb3854918c3d11e286e37e7595f082dad4fc259e33
  CHECKSUM(SHA256) upstream package : 398ac94becdbce3151acc8bb3854918c3d11e286e37e7595f082dad4fc259e33


Generated by fedora-review 0.2.0 (Unknown) last change: Unknown
Buildroot used: fedora-18-x86_64
Command line :./try-fedora-review -b 823340
Comment 2 Julian C. Dunn 2012-12-27 22:11:35 EST
Hi Michael,

Jonas seems to have abandoned his packages that are pre-requisites for Chef, so I am taking them over.

(In reply to comment #1)

> - Gem package should exclude cached Gem. However, It seems to have
> disappeared from the ruby guidelines, but that's still present in the talk
> page :
> https://fedoraproject.org/wiki/Packaging_talk:Ruby
> 
> So i am not sure exactly on what to do. Could you reach ruby-sig and check ?
> ( from what I have seen and read, there is more people who would prefer to
> have them removed than kept, since there isn't much reason to keep the cache
> but I didn't look much )
>
> Except that, the package should be good.

I generally exclude the cached Gems from the package. That seems to be the general consensus from others on ruby-sig who have reviewed my packages. So if there are no other objections please set fedora-review+ & I'll import this as-is with an additional %exclude for it.
Comment 3 Michael Scherer 2012-12-28 04:46:30 EST
Please post the updated spec/srpm, as I prefer to do a last check before approving, in case i missed something 'especially with ruby, I am not that familiar with it, so better check twice ).
Comment 5 Michael Scherer 2012-12-29 06:19:10 EST
You moved the license file out of the main package, and that's against the guideline :

[!]: License file installed when any subpackage combination is installed.

Please correct, otherwise, the other change is good.
Comment 7 Michael Scherer 2012-12-29 22:04:49 EST
So approved.
Comment 8 Julian C. Dunn 2012-12-30 18:49:37 EST
New Package SCM Request
=======================
Package Name: rubygem-ipaddress
Short Description: rubygem abstraction for ipv4, ipv6 addresses
Owners: jdunn
Branches: f16 f17 f18 el6
InitialCC:
Comment 9 Gwyn Ciesla 2013-01-01 13:43:00 EST
Git done (by process-git-requests).
Comment 10 Julian C. Dunn 2013-01-01 20:25:29 EST
(In reply to comment #9)
> Git done (by process-git-requests).

Jon are you sure this worked? "fedpkg clone rubygem-ipaddress" gives "fatal: '/srv/git/rpms//rubygem-ipaddress.git' does not appear to be a git repository"
Comment 11 Fedora Update System 2013-01-01 22:48:24 EST
rubygem-ipaddress-0.8.0-3.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/rubygem-ipaddress-0.8.0-3.el6
Comment 12 Fedora Update System 2013-01-01 22:48:58 EST
rubygem-ipaddress-0.8.0-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/rubygem-ipaddress-0.8.0-3.fc16
Comment 13 Fedora Update System 2013-01-01 22:49:26 EST
rubygem-ipaddress-0.8.0-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/rubygem-ipaddress-0.8.0-3.fc17
Comment 14 Fedora Update System 2013-01-01 22:49:55 EST
rubygem-ipaddress-0.8.0-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/rubygem-ipaddress-0.8.0-3.fc18
Comment 15 Fedora Update System 2013-01-02 14:10:09 EST
rubygem-ipaddress-0.8.0-3.el6 has been pushed to the Fedora EPEL 6 testing repository.
Comment 16 Fedora Update System 2013-01-11 18:19:24 EST
rubygem-ipaddress-0.8.0-3.fc18 has been pushed to the Fedora 18 stable repository.
Comment 17 Fedora Update System 2013-01-12 10:06:03 EST
rubygem-ipaddress-0.8.0-3.fc16 has been pushed to the Fedora 16 stable repository.
Comment 18 Fedora Update System 2013-01-12 10:15:39 EST
rubygem-ipaddress-0.8.0-3.fc17 has been pushed to the Fedora 17 stable repository.
Comment 19 Fedora Update System 2013-01-21 22:33:44 EST
rubygem-ipaddress-0.8.0-3.el6 has been pushed to the Fedora EPEL 6 stable repository.
Comment 20 Troy Dawson 2014-12-18 18:34:38 EST
Package Change Request
======================
Package Name: rubygem-ipaddress
New Branches: epel7
Owners: tdawson
Comment 21 Gwyn Ciesla 2014-12-19 08:29:59 EST
Git done (by process-git-requests).
Comment 22 Julian C. Dunn 2015-01-23 23:59:43 EST
*** Bug 1166734 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.