Bug 823389 - bonnie++ fails with ENOTEMPTY
Summary: bonnie++ fails with ENOTEMPTY
Keywords:
Status: CLOSED DUPLICATE of bug 814052
Alias: None
Product: GlusterFS
Classification: Community
Component: rdma
Version: mainline
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: shishir gowda
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-21 06:28 UTC by Anush Shetty
Modified: 2013-12-09 01:32 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-22 05:01:09 UTC
Regression: ---
Mount Type: nfs
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Anush Shetty 2012-05-21 06:28:36 UTC
Description of problem: Bonnie+= fails with ENOTEMPTY on nfs mount. This happens consistently. Even in the dmesg, nfs complains of readdir loop. When I try deleting the bonnie directory manually again, it gets deleted successfully.

Version-Release number of selected component (if applicable): Upstream


How reproducible: Consistently


Steps to Reproduce:
1. time bonnie++ -u root -d /mnt/gluster
2.
3.
  
Actual results:

Changing to the specified mountpoint
/mnt2/run24665
executing bonnie
Using uid:0, gid:0.
Writing a byte at a time...done
Writing intelligently...done
Rewriting...done
Reading a byte at a time...done
Reading intelligently...done
start 'em...done...done...done...done...done...
Create files in sequential order...done.
Stat files in sequential order...done.
Delete files in sequential order...Bonnie: drastic I/O error (rmdir): Directory not empty
Cleaning up test directory after error.

real    24m46.583s
user    0m0.937s
sys     0m25.466s
bonnie failed


dmesg:
NFS: directory run24665/Bonnie.24687 contains a readdir loop.  Please contact your server vendor.  Offending cookie: 1052004

Expected results:


Additional info:

Comment 1 shishir gowda 2012-05-22 05:01:09 UTC

*** This bug has been marked as a duplicate of bug 814052 ***


Note You need to log in before you can comment on or make changes to this bug.